Bug 495788 - fatal python errors after rollback of errata updates on rhel4
fatal python errors after rollback of errata updates on rhel4
Status: CLOSED DUPLICATE of bug 464772
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.8
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Red Hat Satellite QA List
http://grandprix.rhndev.redhat.com/ne...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-14 15:36 EDT by wes hayutin
Modified: 2009-04-15 08:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 08:44:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-04-14 15:36:10 EDT
Description of problem:
server = 4/13 build x86 rhel5

fatal python errors after rollback of errata updates on rhel4

recreate:
1. register rhel4 client
1.5 create a snapshot tag
2. update the first 25 errata updates listed for that box
3. rhn_check -vvv
4. rollback to the snapshot..

 	This action will be executed after 04/14/09 3:05:03 PM EDT.

This action's status is: Failed.
The client picked up this action on 04/14/09 3:05:05 PM EDT.
The client completed this action on 04/14/09 3:05:22 PM EDT.
Client execution returned "Fatal error in Python code occured [[6]]" (code -1)
Changes Scheduled:

    * Replace NetworkManager-0.3.1-5.el4 with NetworkManager-0.3.1-4.el4
    * Replace ash-0.3.8-20.el4_7.1 with ash-0.3.8-20
    * Replace audit-1.0.16-3.el4_7.1 with audit-1.0.16-3.el4
    * Replace audit-libs-1.0.16-3.el4_7.1 with audit-libs-1.0.16-3.el4
    * Replace autofs-4.1.3-234.el4_7.1:1 with autofs-4.1.3-234:1
    * Replace bash-3.0-19.7.el4_7.1 with bash-3.0-19.7
    * Replace bind-libs-9.2.4-30.el4_7.2:20 with bind-libs-9.2.4-30.el4:20
    * Replace bind-utils-9.2.4-30.el4_7.2:20 with bind-utils-9.2.4-30.el4:20
    * Replace bluez-libs-2.10-3 with bluez-libs-2.10-2
    * Replace bluez-utils-2.10-2.4 with bluez-utils-2.10-2.2
    * Replace bzip2-1.0.2-14.el4_7 with bzip2-1.0.2-13.EL4.3
    * Replace bzip2-libs-1.0.2-14.el4_7 with bzip2-libs-1.0.2-13.EL4.3
    * Replace coreutils-5.2.1-31.8.el4_7.1 with coreutils-5.2.1-31.8.el4
    * Replace cups-1.1.22-0.rc1.9.27.el4_7.1:1 with cups-1.1.22-0.rc1.9.27:1
    * Replace cups-libs-1.1.22-0.rc1.9.27.el4_7.1:1 with cups-libs-1.1.22-0.rc1.9.27:1
    * Replace ed-0.2-36.el4_7.1 with ed-0.2-36
    * Replace glibc-2.3.4-2.41.el4_7.1 with glibc-2.3.4-2.41
    * Replace glibc-common-2.3.4-2.41.el4_7.1 with glibc-common-2.3.4-2.41
    * Remove httpd-2.0.52-41.ent.4
    * Replace httpd-suexec-2.0.52-41.ent.4 with httpd-suexec-2.0.52-41.ent.2
    * Replace ipsec-tools-0.3.3-7.el4_7 with ipsec-tools-0.3.3-6.rhel4.1
    * Remove kernel-2.6.9-78.0.8.EL
    * Replace kernel-utils-2.4-14.1.117.2.1:1 with kernel-utils-2.4-14.1.117:1
    * Replace libtiff-3.6.1-12.el4_7.2 with libtiff-3.6.1-12
    * Replace libxml2-2.6.16-12.6 with libxml2-2.6.16-12
    * Replace libxslt-1.1.11-1.el4_7.2 with libxslt-1.1.11-1.el4_6.1
    * Replace net-snmp-libs-5.1.2-13.el4_7.3 with net-snmp-libs-5.1.2-13.el4
    * Replace nscd-2.3.4-2.41.el4_7.1 with nscd-2.3.4-2.41
    * Replace nss_ldap-253-5.el4_7.1 with nss_ldap-253-5.el4
    * Replace openssh-3.9p1-11.el4_7 with openssh-3.9p1-9.el4
    * Replace openssh-clients-3.9p1-11.el4_7 with openssh-clients-3.9p1-9.el4
    * Replace openssh-server-3.9p1-11.el4_7 with openssh-server-3.9p1-9.el4
    * Replace openssl-0.9.7a-43.17.el4_7.2 with openssl-0.9.7a-43.17.el4_6.1
    * Replace redhat-release-4AS-8.0.el4_7.1 with redhat-release-4AS-8
    * Replace tzdata-2008i-1.el4 with tzdata-2008b-3.el4
    * Replace udev-039-10.22.el4_7.1 with udev-039-10.22.el4
    * Replace vim-common-6.3.046-1.el4_7.5z:1 with vim-common-6.3.046-0.40E.7:1
    * Replace vim-enhanced-6.3.046-1.el4_7.5z:1 with vim-enhanced-6.3.046-0.40E.7:1
    * Replace vim-minimal-6.3.046-1.el4_7.5z:1 with vim-minimal-6.3.046-0.40E.7:1
Comment 1 wes hayutin 2009-04-14 15:36:43 EDT
-server', '3.9p1', '9.el4', '', ''], 'i'], [['openssl', '0.9.7a', '43.17.el4_6.1', '', ''], 'i'], [['redhat-release', '4AS', '8', '', ''], 'i'], [['tzdata', '2008b', '3.el4', '', ''], 'i'], [['udev', '039', 
'10.22.el4', '', ''], 'i'], [['vim-common', '6.3.046', '0.40E.7', '1', ''], 'i'], [['vim-enhanced', '6.3.046', '0.40E.7', '1', ''], 'i'], [['vim-minimal', '6.3.046', '0.40E.7', '1', ''], 'i']]},)
[Tue Apr 14 15:21:24 2009] up2date allAvailablePackageList from network
[Tue Apr 14 15:21:24 2009] up2date availablePackageList::channels:<up2date_client.rhnChannel.rhnChannelList instance at 0xb7af2c4c>
[Tue Apr 14 15:21:26 2009] up2date listAllPackages Fetched via:diskcache
[Tue Apr 14 15:21:35 2009] up2date getPackage['NetworkManager', '0.3.1', '4.el4', '', 'i386', '89332', 'rhel-i386-as-4']
[Tue Apr 14 15:21:35 2009] up2date Package ['NetworkManager', '0.3.1', '4.el4', '', 'i386', '89332', 'rhel-i386-as-4'] Fetched via: diskcache
[Tue Apr 14 15:21:35 2009] up2date getPackage['ash', '0.3.8', '20', '', 'i386', '341500', 'rhel-i386-as-4']
[Tue Apr 14 15:21:35 2009] up2date Sending back response((6,), 'Fatal error in Python code occured', {})
[Tue Apr 14 15:21:35 2009] up2date do_callpackages.checkNeedUpdate('rhnsd=1',)
[Tue Apr 14 15:21:35 2009] up2date local action status: (0, 'rpm database not modified since last update (or package list recently updated)', {})
Comment 2 wes hayutin 2009-04-14 16:03:13 EDT
, ''], 'i'], [['openssl', '0.9.7a', '43.17.el4_6.1', '', ''], 'i'], [['redhat-release', '4AS', '8', '', ''], 'i'], [['tzdata', '2008b', '3.el4', '', ''], 'i'], [['udev', '039', '10.22.el4', '', ''], 'i'], [['vim-common', '6.3.046', '0.40E.7', '1', ''], 'i'], [['vim-enhanced', '6.3.046', '0.40E.7', '1', ''], 'i'], [['vim-minimal', '6.3.046', '0.40E.7', '1', ''], 'i']]},)
D: availablePackageList::channels: <up2date_client.rhnChannel.rhnChannelList instance at 0xb7a56c4c>
D: listAllPackages Fetched via: diskcache
D: getPackage ['NetworkManager', '0.3.1', '4.el4', '', 'i386', '89332', 'rhel-i386-as-4']
D: Package ['NetworkManager', '0.3.1', '4.el4', '', 'i386', '89332', 'rhel-i386-as-4'] Fetched via: diskcache
D: getPackage ['ash', '0.3.8', '20', '', 'i386', '341500', 'rhel-i386-as-4']
D: Package ['ash', '0.3.8', '20', '', 'i386', '341500', 'rhel-i386-as-4'] Fetched via: diskcache
D: getPackage ['audit', '1.0.16', '3.el4', '', 'i386', '206939', 'rhel-i386-as-4']
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 174, in run_action
    (status, message, data) = do_call(method, params)
  File "/usr/sbin/rhn_check", line 91, in do_call
    retval = apply(method, params)
  File "/usr/share/rhn/actions/packages.py", line 428, in runTransaction
    (ts, added, removed) = up2date.genTransaction(tsd)
  File "/usr/share/rhn/up2date_client/up2date.py", line 609, in genTransaction
    getPackage(package)
  File "/usr/share/rhn/up2date_client/up2date.py", line 180, in getPackage
    buf = rpcServer.doCall(repos.getPackage, pkg, msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 238, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 37, in getPackage
    return self.handlers[channel['type']].getPackage(pkg, msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 186, in getPackage
    package = source.getPackage(pkg, MsgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py", line 216, in getPackage
    progressCallback(1,1)
TypeError: 'NoneType' object is not callable
D: Sending back response ((6,), 'Fatal error in Python code occured', {})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})
[root@fjs-0-19 ~]#

Note You need to log in before you can comment on or make changes to this bug.