Bug 495813 - gct-tool not compiled with openssl support
gct-tool not compiled with openssl support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gwenhywfar (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-14 18:05 EDT by Frank Häfemeier
Modified: 2014-03-16 23:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 11:53:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Häfemeier 2009-04-14 18:05:29 EDT
Description of problem:
The tool gct-tool in package gwenhywfar-devel is not compiled with OpenSSL support. This support is needed to update old OpenHBCI keyfiles (with OpenSSL style password) to the new crypt token format.

Version-Release number of selected component (if applicable):
3.7.2-1

How reproducible:


Steps to Reproduce:
1. Call 'ldd /usr/bin/gct-tools'
2.
3.
  
Actual results:
	linux-vdso.so.1 =>  (0x00007fff66dfe000)
	libgwenhywfar.so.47 => /usr/lib64/libgwenhywfar.so.47 (0x0000003807e00000)
	libc.so.6 => /lib64/libc.so.6 (0x0000003806a00000)
	libgcrypt.so.11 => /lib64/libgcrypt.so.11 (0x0000003817000000)
	libgpg-error.so.0 => /lib64/libgpg-error.so.0 (0x0000003816000000)
	libgnutls.so.26 => /usr/lib64/libgnutls.so.26 (0x000000381c000000)
	librt.so.1 => /lib64/librt.so.1 (0x0000003808200000)
	libdl.so.2 => /lib64/libdl.so.2 (0x0000003807200000)
	/lib64/ld-linux-x86-64.so.2 (0x0000003806600000)
	libtasn1.so.3 => /usr/lib64/libtasn1.so.3 (0x000000381b400000)
	libz.so.1 => /lib64/libz.so.1 (0x0000003807a00000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003807600000)


Expected results:
At least the following library print out:
	libssl.so.8 => /usr/lib64/libssl.so.8 (0x0000003815000000)

Additional info:
Comment 1 Bill Nottingham 2009-04-15 11:53:44 EDT
Fixed in -2.
Comment 2 Bill Nottingham 2009-04-15 11:53:50 EDT
Fixed in -2.

Note You need to log in before you can comment on or make changes to this bug.