Bug 495817 - Not removing existing partitions?
Not removing existing partitions?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 519255 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-14 18:50 EDT by Orion Poplawski
Modified: 2009-11-30 06:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-30 06:02:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vt3 screenshot (29.59 KB, image/png)
2009-04-14 18:50 EDT, Orion Poplawski
no flags Details
fdisk -l screenshot (21.88 KB, image/png)
2009-04-14 18:51 EDT, Orion Poplawski
no flags Details
storage.log (13.94 KB, text/plain)
2009-04-17 15:16 EDT, Orion Poplawski
no flags Details
storage.log (18.06 KB, text/plain)
2009-09-03 10:40 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2009-04-14 18:50:48 EDT
Created attachment 339591 [details]
vt3 screenshot

Description of problem:

Trying to do xen install into 10GB virtual disk.  This has been working fine till now.  Today I get:

Could not allocate requested partitions:

not enough free space on disks.

kickstart part commands are:

clearpart --linux
part / --fstype ext3 --size=3000 --grow
part swap --recommended
bootloader --location=mbr
Comment 1 Orion Poplawski 2009-04-14 18:51:54 EDT
Created attachment 339592 [details]
fdisk -l screenshot
Comment 2 Chris Lumens 2009-04-15 17:20:32 EDT
Could you please attach /tmp/storage.log to this bug report?  Thanks.
Comment 3 Orion Poplawski 2009-04-17 15:16:47 EDT
Created attachment 340073 [details]
storage.log

Looks like it's not recognizing the type of partition /dev/xvda1.  May be in an indeterminate state from a previously aborted install.
Comment 4 Chris Lumens 2009-05-19 11:22:22 EDT
Is this still a problem?
Comment 5 Orion Poplawski 2009-05-19 12:03:15 EDT
Well, I can still reproduce by copy the following:

http://sw.cora.nwra.com/test/xenfdev64.bz2

into a xen disk image.  This has the results of an aborted install which must have left the disk with partitions marked "Linux", but no recognizable filesystem in partition 1.


Easy enough to zero out the xen disk image to work around though.
Comment 6 Chris Lumens 2009-06-08 15:37:34 EDT
I'm not sure what the correct answer is here.  What happens if you use clearpart --all?  Or, can you not use that for some reason?
Comment 7 Bug Zapper 2009-06-09 09:50:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Orion Poplawski 2009-09-03 10:40:11 EDT
Seeing this with today's rawhide.  I can't use clearpart --all in general because I re-use some of these kickstart file for installs on dual-boot machines.  I don't see why anaconda would not clear a partition marked "Linux" in the partition table and unknown contents with "clearpart --linux" set.
Comment 9 Orion Poplawski 2009-09-03 10:40:57 EDT
Created attachment 359688 [details]
storage.log
Comment 10 Chris Lumens 2009-09-03 10:50:25 EDT
Linux partitions are those with a "linux filesystem" on them.  This includes things like ext3, ext4, etc.  If you've got unknown contents on there, anaconda's going to ignore them.  Do you know what's on xvda1?  anaconda certainly can't figure it out.
Comment 11 Orion Poplawski 2009-09-03 11:05:30 EDT
But anaconda can recognize most "real" filesystems out there, right?  And it know that it's not one of those either.

I guess what irks me the most is that this system is in a state left from a failed anaconda install - where it labeled the partitions but never got to making the file systems.  It seems like anaconda should be able to recover from that state.
Comment 12 David Lehman 2009-09-03 18:23:57 EDT
*** Bug 519255 has been marked as a duplicate of this bug. ***
Comment 13 Bug Zapper 2009-11-16 04:55:09 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Hans de Goede 2009-11-30 06:02:25 EST
In F-11 and later "clearpart --linux" does not look at what the partition table
entry type says (the 83 normally), but actually looks at what sort of filesystem is on the partition as the partition table entry type is not a very reliable indicator of what a partition is actually used for.

So if you have a hosed partition you want to reuse, you need to use
"clearpart --all", or manually remove the partition from the table before installing.

Note You need to log in before you can comment on or make changes to this bug.