Bug 495830 - glibc is not updated cause glibc_post_upgrade.i686 is hang.
glibc is not updated cause glibc_post_upgrade.i686 is hang.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-14 21:54 EDT by Masao Takahashi
Modified: 2009-04-16 20:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 17:08:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ldconfig log (4.97 KB, text/plain)
2009-04-16 00:55 EDT, Masao Takahashi
no flags Details
a strace log of ldconfig-2.9.90-17 (381.67 KB, application/octet-stream)
2009-04-16 04:40 EDT, Masao Takahashi
no flags Details

  None (edit)
Description Masao Takahashi 2009-04-14 21:54:07 EDT
Description of problem:
When I update glibc-2.9.90-11.i686 to glibc-2.9.90-16.i686,
update process is pending cause glibc_post_upgrade.i686 is hang.
So, I can't update glibc.


Version-Release number of selected component (if applicable):
glibc-2.9.90-16.i686

How reproducible:

Whenever updating glibc to 2.9.90-16

Steps to Reproduce:
1. rpm -Uvh glibc-2.9.90-16.i686.rpm ......
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Masao Takahashi 2009-04-14 21:57:27 EDT
I add a rpm log as follows.

D:   install: %post(glibc-2.9.90-16.i686) synchronous scriptlet start
D:   install: %post(glibc-2.9.90-16.i686)	execv(/usr/sbin/glibc_post_upgrade.i686) pid 11719
^CD:   install: waitpid(11719) rc 11719 status 2 secs 122.265
error: %post(glibc-2.9.90-16.i686) scriptlet failed, signal 2
Comment 2 Masao Takahashi 2009-04-16 00:54:16 EDT
An additional info:
glibc_post_upgrade.i686 is waiting for completion of ldconfig.
ldconfig is hang. Not glibc_post_upgrade.
I add a ldconfig log.
Comment 3 Masao Takahashi 2009-04-16 00:55:08 EDT
Created attachment 339785 [details]
ldconfig log
Comment 4 Masao Takahashi 2009-04-16 00:56:07 EDT
glibc-2.9.90-17.i686 has a same problem.
Comment 5 Jakub Jelinek 2009-04-16 03:35:32 EDT
Does ldconfig also hang if you just run it from command line?
Can you run top once that happens to see if it consumes CPU time or not?
Can you strace it to see what it does last?  Can you check dmesg if you don't have say filesystem/disk errors?

There haven't been any ldconfig changes since mid 2007...
Comment 6 Masao Takahashi 2009-04-16 03:46:29 EDT
(In reply to comment #5)
> Does ldconfig also hang if you just run it from command line?
 After I invoke glibc_post_upgrade.i686, glibc_post_upgrade.i686 executes 
ldconfig and waits for it's completion.
But ldconfig doesn't complete.

> Can you run top once that happens to see if it consumes CPU time or not?
It does not consume CPU time.
> Can you strace it to see what it does last?  Can you check dmesg if you don't
I check dmesg. But no erros are found.
I did strace. The last was "fuke" , perhaps.
> have say filesystem/disk errors?
> 
> There haven't been any ldconfig changes since mid 2007...
Comment 7 Masao Takahashi 2009-04-16 03:55:12 EDT
strace last message:
Bad : fuke
Correct : futex
Comment 8 Jakub Jelinek 2009-04-16 04:08:06 EDT
Can you please attach the full strace dump?  Given that ldconfig isn't multithreaded, nor doesn't use process wide synchronization primitives, I highly doubt ldconfig ever does even a single futex call.
Comment 9 Masao Takahashi 2009-04-16 04:40:54 EDT
Created attachment 339813 [details]
a strace log of ldconfig-2.9.90-17 

I add a strace log of ldconfig-2.9.90-17.
  strace -f ldconfig 2>ldconfig.log

But, glibc-2.9.90-11 is good.
Comment 10 Jakub Jelinek 2009-04-16 04:54:17 EDT
Please run
LC_ALL=C ldconfig
and see what error it actually attempts to report, the problem is I assume during transcoding of the error message.
Comment 11 Masao Takahashi 2009-04-16 05:20:32 EDT
(In reply to comment #10)
> Please run
> LC_ALL=C ldconfig
> and see what error it actually attempts to report, the problem is I assume
> during transcoding of the error message.  
I did it.
ldconfig output is as follows.
And ldconfig is completed.
You are right.
What shall i do?
--------------------------------------------------------
ldconfig: /usr/lib/libreadline.so.5 is not a symbolic link

ldconfig: /usr/lib/libbz2.so.1 is not a symbolic link

ldconfig: /usr/lib/libz.so.1 is not a symbolic link

ldconfig: /usr/lib/libpopt.so.0 is not a symbolic link

ldconfig: /usr/lib/libneon.so.25 is not a symbolic link

ldconfig: /usr/lib/libncurses.so.5 is not a symbolic link

ldconfig: /usr/lib/libncursesw.so.5 is not a symbolic link

ldconfig: /usr/lib/libparted-1.7.so.1 is not a symbolic link

ldconfig: /usr/lib/libwrap.so.0 is not a symbolic link
--------------------------------------------------------
Comment 12 Jakub Jelinek 2009-04-16 17:08:11 EDT
Should be fixed in glibc-2.9.90-19.
Comment 13 Masao Takahashi 2009-04-16 20:07:37 EDT
(In reply to comment #12)
> Should be fixed in glibc-2.9.90-19.  

Yes glibc-2.9.90-19 is good.

Note You need to log in before you can comment on or make changes to this bug.