This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 495870 - kdeutils-printer-applet dependency bloat
kdeutils-printer-applet dependency bloat
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 05:30 EDT by Ville Skyttä
Modified: 2009-04-16 08:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 06:54:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Suggested fix (877 bytes, patch)
2009-04-15 05:30 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2009-04-15 05:30:35 EDT
Created attachment 339659 [details]
Suggested fix

kdeutils-printer-applet has quite a dependency chain for nothing on systems that have no need for printing stuff:

================================================================================
 Package                      Arch     Version          Repository         Size
================================================================================
Installing:
 kdeutils-printer-applet      x86_64   6:4.2.2-2.fc10   updates-testing    33 k
Installing for dependencies:
 PyKDE4                       x86_64   4.2.2-2.fc10     updates-testing   4.8 M
 PyQt4                        x86_64   4.4.4-5.fc10     updates           3.2 M
 foomatic                     x86_64   3.0.2-70.fc10    updates            19 M
 hal-cups-utils               x86_64   0.6.19-1.fc10    updates            41 k
 sip                          x86_64   4.7.9-1.fc10     updates           240 k
 system-config-printer-libs   x86_64   1.0.16-2.fc10    updates           903 k

Transaction Summary
================================================================================
Install      7 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

Total download size: 28 M

I think the "don't disappear on upgrades" intention can be taken care of less intrusively, see attached (untested) patch against Rawhide.
Comment 1 Ngo Than 2009-04-15 06:54:22 EDT
it's fixed in 4.2.2-3
Comment 2 Rex Dieter 2009-04-15 11:16:09 EDT
Not sure I like this, now the bloat is the other way around.

Now, kdeutils-printer-applet needlessly Requires: kdeutils
Comment 3 Rex Dieter 2009-04-15 11:27:05 EDT
I guess there's suckage either way, depends on which case is least bad:
kdeutils Requires: -printer-applet
or 
-printer-applet Requires: kdeutils

ie, which is the more significant use case:
having kdeutils installed without wanting -printer-applet
having -printer-applet installed without kdeutils

The more I think about it, maybe the former (status-quo) is indeed preferable, but I'd like to hear other's thoughts on the matter.
Comment 4 Rex Dieter 2009-04-15 11:28:28 EDT
We could also consider dropping the requires (esp for f11), and let comps handle it.
Comment 5 Kevin Kofler 2009-04-15 11:40:35 EDT
It should be added that the printer applet has been shipped in kdeutils since the F10 release, so the dependency chain is not really new. Having printer stuff dragged in even when not using a printer is an old problem.

I think we should keep F-9 and F-10 as they are now (i.e. revert them in CVS and not push the build) and just drop the Requires for F11+.
Comment 6 Ville Skyttä 2009-04-15 18:10:18 EDT
(In reply to comment #5)
> It should be added that the printer applet has been shipped in kdeutils since
> the F10 release, so the dependency chain is not really new.

Well, it's new to me, I upgraded to F-10 a few weeks ago.  Anyway, I already got annoyed by it when upgrading from F-9 to F-10, did a --nodeps install of kdeutils to "fix" it then, and just ran into it again when upgrading stuff from F-10 updates-testing, this time got around to reporting it.

> Having printer
> stuff dragged in even when not using a printer is an old problem.

Yep, and one that I thought was already a thing of the past until this incident occurred, I hadn't run into it in quite a long time.
 
> I think we should keep F-9 and F-10 as they are now (i.e. revert them in CVS
> and not push the build) and just drop the Requires for F11+.  

Not sure which Requires you mean, but if the one added by the patch I posted: note that if that Requires is dropped, the Obsoletes should go too.  Only if they're both there the desirable kdeutils -> kdeutils+kdeutils-printer-applet upgrade scenario happens.  If the Requires is dropped and Obsoletes kept, it becomes kdeutils -> kdeutils-printer-applet (kdeutils gets lost on upgrade).

If on the other hand you mean dropping the original Requires: kdeutils-printer-applet in kdeutils that was there before my patch, I think that'd be an ok approach for F-11+.
Comment 7 Kevin Kofler 2009-04-15 19:02:59 EDT
Yes, I mean dropping the original Requires, i.e. having kdeutils and kdeutils-printer-applet neither require nor obsolete each other in F11.
Comment 8 Ngo Than 2009-04-16 05:28:09 EDT
>I guess there's suckage either way, depends on which case is least bad:
>kdeutils Requires: -printer-applet
>or 
>-printer-applet Requires: kdeutils
>ie, which is the more significant use case:
>having kdeutils installed without wanting -printer-applet
>having -printer-applet installed without kdeutils

we should revert the change for F9/f10 so that printer-applet will be installed by upgrade.

>We could also consider dropping the requires (esp for f11), and let comps
>handle it.  

yes, For F11, we dropp the original Requires and just let comps handle it


any objection?
Comment 9 Rex Dieter 2009-04-16 08:32:41 EDT
re: comment #8   +1 , I think we're all in agreement here.

Note You need to log in before you can comment on or make changes to this bug.