Bug 49596 - RFE: OS commonly installed on FAT partitions is now called `windows'
Summary: RFE: OS commonly installed on FAT partitions is now called `windows'
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-21 02:04 UTC by Mike MacCana
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-27 19:11:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike MacCana 2001-07-21 02:04:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686; Nav)

Description of problem:
The installer gives OSs installed on FAT12 / FAT16 / FAT32 partitions the
name of `dos'. This isn't correct. The DOS kernel was renamed Windows in
1995. Windows NT can also be installed on MSDOS partitions, and, oddly
enough, is also called `windows'.

How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat on a dual boot system
2. Examing the name the installer gives to lilo to refer to OSs installed
on FAT partitiions.
	
	

Actual Results:  It says `dos'

Expected Results:  It should say `windows'

Additional info:

Comment 1 Michael Schwendt 2001-07-21 16:38:56 UTC
Even better, the user should be able to change the default name at install time,
so one could choose "win", for instance. And people who have a plain DOS on
FAT12 or FAT16 would not be forced to use "windows". Btw, "dos" is faster to
type than "windows" in LILO. ;-)  If you don't like it, change and re-write
/etc/lilo.conf after installation.

Comment 2 Mike MacCana 2001-07-21 22:27:09 UTC
* The user can change the amee at install time, if I remeber correctly
* Lilo defaults to graphical mode on recent versions of Red Hat, so character 
length isn't really important.
* The 99.9% of people using Windows on FAT partitions shouldn't have to change 
lilo.conf.

Comment 3 Michael Schwendt 2001-07-22 12:08:53 UTC
So, since the user knows exactly what kind of OS is installed on his non-Linux
partitions, he's free to change the default name.

Comment 4 Doug Ledford 2001-08-02 18:05:38 UTC
This isn't a lilo issue.  Lilo uses whatever name is in the lilo.conf file. 
That name is put there by the install code (anaconda).  I'm chaning the
component and the install guys can decide if this issue merits doing anything
about.

Comment 5 Brent Fox 2001-08-09 20:03:13 UTC
I'll mark this as an RFE.  We are in a feature freeze at the moment, so I'll
defer this until a future release.

Comment 6 Jeremy Katz 2002-01-22 01:08:35 UTC
Changed in cvs


Note You need to log in before you can comment on or make changes to this bug.