Bug 495960 - Misleading messages
Misleading messages
Status: CLOSED WONTFIX
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Guiditta
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 14:02 EDT by Mike McGrath
Modified: 2014-07-06 15:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-22 11:03:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McGrath 2009-04-15 14:02:03 EDT
When i try to do something in ovirt, like start a guest, it tells me that the request has been successfully queued.  The problem is I wasn't trying to queue something, I was trying to start a guest.  Also if the guest fails to startup, there should be some wui output of that as well as an error message.
Comment 1 Scott Seago 2009-05-21 14:49:53 EDT
I'm not sure what to do here other than perhaps come up with clearer messages. Any action that involves libvirt does queue a task, as it's an asynchronous action. The main thing missing here is a way for task completion (which happens later) to automatically update the web UI for a user when a recently-queued task completes.

So to get any failure-to-startup message will require some sort of polling or other notification for later actions to update the display. The difficulty here is that when the web request finishes we don't know if the start succeeded, since the back end process hasn't processed it yet -- all we know is that it's been successfully queued.

I'm assigning this to Jay now as he's done a bit of thinking around how to handle the auto-update for asynchronous tasks.
Comment 2 Hugh Brock 2009-05-22 14:06:53 EDT
I think this is important but it's a bigger chunk of work (and requires more serious thinking) than we can take on for 0.99. Pushing to next release.

Note You need to log in before you can comment on or make changes to this bug.