Bug 495966 - (evolution:<PID>): GLib-CRITICAL **: g_strv_length: assertion `str_array != NULL' failed
(evolution:<PID>): GLib-CRITICAL **: g_strv_length: assertion `str_array != N...
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
All Linux
low Severity low
: rc
: ---
Assigned To: Matthew Barnes
: EasyFix, Patch
Depends On:
  Show dependency treegraph
Reported: 2009-04-15 14:31 EDT by Chris Evich
Modified: 2014-03-07 09:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-03-07 09:58:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch to make sure opt_remaining is non-null before asking glib to count it's elements. (473 bytes, patch)
2009-04-15 14:31 EDT, Chris Evich
no flags Details | Diff

  None (edit)
Description Chris Evich 2009-04-15 14:31:21 EDT
Created attachment 339733 [details]
Patch to make sure opt_remaining is non-null before asking glib to count it's elements.

Description of problem:
Executing evolution-addressbook-export with options or not produces this "critical" error.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. /usr/libexec/evolution/2.12/evolution-addressbook-export > /dev/null
Actual results:
Critical message is printed.

Expected results:
No critical messages.

Additional info:
one-line patch.
Comment 3 RHEL Product and Program Management 2014-03-07 08:46:22 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 Chris Evich 2014-03-07 09:58:52 EST
Since this is not an issue in RHEL 6, low-priority for RHEL 5, safe to close as know condition that won't be fixed in this release.

Note You need to log in before you can comment on or make changes to this bug.