Bug 495998 - Weather applet forgets its configuration
Weather applet forgets its configuration
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kde-plasma-weather (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 17:53 EDT by Ville Skyttä
Modified: 2009-04-27 17:37 EDT (History)
8 users (show)

See Also:
Fixed In Version: 1.0.0-6.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 17:37:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2009-04-15 17:53:19 EDT
After upgrading kde* to 4.2.2 and qt* to 4.5 from current F-10 updates-testing, kde-plasma-weather has started to forget its configuration, I have to reconfigure it on every login.  When I go to the config in the lost config scenario, it shows "PopupApplet" as the selected city, not "Helsinki" (from the BBC source) as I configured it previously.

~/.kde/share/config/plasma-appletsrc looks ok, it contains my config.

This problem started occurring after the updates-testing upgrades, no such problems before.
Comment 1 Shawn Starr 2009-04-15 20:26:51 EDT
Depending on which patches Fedora has taken This is fixed in KDE trunk (what will be KDE 4.3) however, if they did backport this fix. You will need to remove the weather applet from your plasma-appletsrc config *BEFORE* plasma is started otherwise do this:

1) start konsole

2) run kquitapp plasma-desktop (or plasma)

3) edit your plasma-appletsrc and remove all references of weather plasmoid.

4) load plasma again (type plasma or plasma-desktop)

5) add weather plasmoid back, see if this works, if not then we need to backport the fix from kdelibs/libplasma in 4.3
Comment 2 Ville Skyttä 2009-04-16 13:08:43 EDT
Tried the recipe in comment 1, it does not make any difference.

BTW, all other settings besides the city I've chosen seem to be ok (also before trying the stuff in comment 1).
Comment 3 Kevin Kofler 2009-04-20 17:05:38 EDT
This should be fixed in kdelibs-4.2.2-8 (by a libplasma change). Can anybody please test?
F11 build: http://koji.fedoraproject.org/koji/buildinfo?buildID=98704
F10 build: http://koji.fedoraproject.org/koji/buildinfo?buildID=98705
F9 build: http://koji.fedoraproject.org/koji/buildinfo?buildID=98706
Comment 4 Ville Skyttä 2009-04-21 15:02:39 EDT
Tested with 4.2.2-9.fc10.x86_64, works, although required saving the changes one more time in a session started after the update was installed, which I suppose means that old applet configs are not automatically fixed/migrated but need user intervention.
Comment 5 Rex Dieter 2009-04-21 15:22:27 EDT
old applet configs should get migrated on next login (via kconf_update)
Comment 6 Ville Skyttä 2009-04-21 16:44:59 EDT
I'm almost certain that it didn't happen for me; IIRC what I did was:

1) Update kdelibs and kdelibs-common to 4.2.2-9.fc10.x86_64 while KDE is running, weather applet configured and running too, settings saved
2) Logout & login
3) Notice weather applet again in unconfigured state
4) Configure weather applet, click ok, shows weather normally again
5) Logout & login
6) Success, weather applet remembers its config

FWIW, I upgraded to -9.fc10 from -5.fc10.
Comment 7 Fedora Update System 2009-04-22 06:29:29 EDT
kdelibs-4.2.2-9.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kdelibs-4.2.2-9.fc10
Comment 8 Fedora Update System 2009-04-22 06:31:24 EDT
kdelibs-4.2.2-9.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kdelibs-4.2.2-9.fc9
Comment 9 Kevin Kofler 2009-04-23 17:37:55 EDT
Re comment #6, my kconf_update script was broken. (Thanks to MathStuf who made me realize where I screwed up.)

I'm now building fixed builds which should sort it out:
F11: http://koji.fedoraproject.org/koji/buildinfo?buildID=99383
F10: http://koji.fedoraproject.org/koji/buildinfo?buildID=99384
F9: http://koji.fedoraproject.org/koji/buildinfo?buildID=99385

This time I'll test it myself to prevent any further bad surprises, sorry.

The effects of the broken kconf_update script are mostly harmless, just a bogus "plasmarc,plasmoidviewer-appletsrc" (yes, with the comma) file getting created. So the fixed script should fix it for good.
Comment 10 Kevin Kofler 2009-04-23 18:29:56 EDT
Hmmmph, this doesn't work as supposed either, it marks the updates as applied to the correct files, but they don't actually end up changed. Yet when I run the script on the plasma-appletsrc by hand, it works as expected? Looks like Plasma breaks things by keeping saving the old stuff even after the update ran. :-(
Comment 11 Kevin Kofler 2009-04-23 19:00:16 EDT
Actually, I figured out where I screwed up, I have to add # DELETEGROUP comments to get kconf_update to actually delete the unwanted groups.

New attempts at fixing:
F11: http://koji.fedoraproject.org/koji/buildinfo?buildID=99393
F10: http://koji.fedoraproject.org/koji/buildinfo?buildID=99394
F9: http://koji.fedoraproject.org/koji/buildinfo?buildID=99395

You will need to restart Plasma for the fixes to take effect and I still can't guarantee there won't be race conditions. Let's see if it at least passes my own test this time. :-)
Comment 12 Kevin Kofler 2009-04-23 19:43:19 EDT
Grrr, the # DELETEGROUP didn't really change anything. Looks like I really can't fix this any further with kconf_update due to how Plasma works. :-(
Comment 13 Kevin Kofler 2009-04-23 21:52:13 EDT
This stuff just causes more problems than it solves. I'm reverting the kdelibs backports, I'll instead just make the weather applet ignore the "PopupApplet" group. I have to do that anyway because I can't get kconf_update to delete it reliably.
Comment 14 Fedora Update System 2009-04-26 01:34:53 EDT
kde-plasma-weather-1.0.0-6.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kde-plasma-weather-1.0.0-6.fc10
Comment 15 Fedora Update System 2009-04-26 01:35:36 EDT
kde-plasma-weather-1.0.0-6.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kde-plasma-weather-1.0.0-6.fc9
Comment 16 Kevin Kofler 2009-04-26 18:51:12 EDT
I asked for kde-plasma-weather-1.0.0-6.fc11 to be tagged into the Fedora 11 release: https://fedorahosted.org/rel-eng/ticket/1642
Comment 17 Fedora Update System 2009-04-27 17:20:40 EDT
kde-plasma-weather-1.0.0-6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2009-04-27 17:36:56 EDT
kde-plasma-weather-1.0.0-6.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.