Bug 496011 - Spanish voices available for Festival
Spanish voices available for Festival
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: festival (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
http://olea.org/tmp/festival/
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 19:17 EDT by Ismael Olea
Modified: 2009-06-30 17:27 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.96-12.fc11
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 17:27:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ismael Olea 2009-04-15 19:17:58 EDT
I've packaged into festival the Spanish voices (Hispavoces[1]) developed by the Andalusian Government for their Linux Distro[2]. They contracted a profesional company for quality voices for their a11y regulation needs.

You've the files at http://olea.org/tmp/festival/

I choose to follow the present trend of including all voices into festival. I didn't named the packages as festvox-* since they are not distributed by them.

It's almost trivial to include in the present festival distribution and I think all the needed information is provided in the package.

Feel free to ask any info you could need.

[1] http://forja.guadalinex.org/repositorio/projects/hispavoces/
[2] http://guadalinex.org
Comment 1 Matthias Clasen 2009-04-17 18:33:07 EDT
I recommend just doing a separate package.
One source tarball, one package is a good rule.
Comment 2 Ismael Olea 2009-04-17 20:47:53 EDT
Well, my only concern here is not promoting non-English languages as less privileged ones. I see the point of not bloating the festival src with tons of voice files but...

If possible, I would ask you please to consider this idea. Maybe creating a separate package for the festvox English voices too. Hopefuly this could be the seed of a little Fedora policy for packaging synthetic voices.

How do you see it?
Comment 3 Matthias Clasen 2009-04-18 17:42:08 EDT
On second thought, since there's already a ton of voice tarballs in the festival package, it is probably fine to just continue with this.
Comment 4 Matthias Clasen 2009-04-18 18:24:52 EDT
However, I have some doubt about the copyright. Looking at the /usr/share/doc/festvox-sflpc16k/doc-pak/copyright file in the Debian packages on the guadalinex website, I see:



This distribution falls under the following copyright
(i.e. with commercial restriction).  See notes below.


              Junta de Andalucía
              Copyright (c) 2007                         
             All Rights Reserved.                           
                                     

This package was generated and the source files were provided by 
MP Sistemas and Intelligent Dialogue Systems S.L. (INDISYS)
Contact person: <packmaster@guadalinex.org>


This development is based on the previous work of the University of
Edimburgh on 'ellpc11k' Spanish male voice.
(Package available at
http://packages.debian.org/stable/sound/festvox-ellpc11k)



The troublesome parts here are the reference to 'commercial restriction', and the fact that this work is derived from festvox-ellpc11k, which was deemed not suitable for Fedora for license reasons, iirc.
Comment 5 Ismael Olea 2009-04-20 04:45:44 EDT
(In reply to comment #4)

> The troublesome parts here are the reference to 'commercial restriction', and
> the fact that this work is derived from festvox-ellpc11k, which was deemed not
> suitable for Fedora for license reasons, iirc.  

Hum.

I'm not really sure where that doc cames from since the debian packaging info[1] is clear about adding the GPL license.

[1] http://v4.guadalinex.org/guadalinex-toro/pool-test/main/f/festival-spanish-voices/festival-spanish-voices_1.0.0.diff.gz

[...]

Well: I've been chatting with the Guadalinex Project manager (Alfonso de Cala). He has been very clear:

- since they have developed the new voices completely from scratch they have full control of all the data and sources for _these_ Spanish voices, the commercial restritions is from festvox version;
- he ratifies the GPL2+ licencing;

In some time they'll publish a release with better copyright explanation, dunno when exactly.

I know this guy personally so I'm sure the information is correct. It's enough for you?
Comment 6 Matthias Clasen 2009-04-20 11:43:19 EDT
Yeah, sounds good to me.
Comment 7 Matthias Clasen 2009-04-20 18:23:44 EDT
I've built festival-1.96-12.fc12 with these new subpackages.

We can look at backporting to f11 when the freeze lifts.
Comment 8 Ismael Olea 2009-04-20 18:41:21 EDT
Great news!!

Thanks!
Comment 9 John Poelstra 2009-06-08 15:29:11 EDT
Adding 'FutureFeature' keyword to avoid rawhide rebase.
Comment 10 Fedora Update System 2009-06-11 02:20:08 EDT
festival-1.96-12.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/festival-1.96-12.fc11
Comment 11 Fedora Update System 2009-06-15 22:42:36 EDT
festival-1.96-12.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update festival'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6473
Comment 12 Fedora Update System 2009-06-30 17:27:48 EDT
festival-1.96-12.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.