Bug 49602 - Using GCC get internal error and seg fault compiling lame 3.89
Using GCC get internal error and seg fault compiling lame 3.89
Status: CLOSED DUPLICATE of bug 38131
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-21 05:40 EDT by Ben Odom
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tabinit.i created by above (101.97 KB, text/plain)
2001-07-28 19:48 EDT, redhat-bugs2eran
no flags Details

  None (edit)
Description Ben Odom 2001-07-21 05:40:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.7 i686; en-US; rv:0.9.1)
Gecko/20010622

Description of problem:
Compiler seg faults when compiling lame version 3.89 when enabling some
optimization options.  Exact optimizations listed in steps below.

How reproducible:
Always

Steps to Reproduce:
1.get latest version of lame 3.89

2../configure --enable-nasm --enable-mp3x --enable-mp3rtp --enable-brhist
--enable-all-float --enable-expopt=full
3.
	

Actual Results:  tabinit.c: In function `make_decode_tables':
tabinit.c:122: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [tabinit.lo] Error 1
make[2]: Leaving directory `/home/me/mp3_maker/lame-3.89/mpglib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/me/mp3_maker/lame-3.89'
make: *** [all-redirect] Error 2


Expected Results:  Program should have compiled and created lame to make
many mp3's.

Additional info:

I have updated all aspects of system using Red Carpet

Linux version 2.4.7 (me@penguinpwr) (gcc version 2.96 20000731 (Red Hat
Linux 7.1 2.96-85)) #1 Fri Jul 20 23:41:10 PDT 2001
Comment 1 Jakub Jelinek 2001-07-25 07:34:54 EDT
Is it reproduceable? If yes, can you rerun the g++ or gcc command line
which causes the ICE/segfault after adding -save-temps to it, enter here
the exact command line and attach the resulting .i or .ii file
(in the above case it would be tabinit.i)?
Comment 2 redhat-bugs2eran 2001-07-28 19:43:31 EDT
Using gcc-2.96-94:
% wget ftp://lame.sourceforge.net/pub/lame/src/lame3.89beta.tar.gz
% tar xzvf lame*.tgz
% cd lame-3.89/mpglib
% gcc -DHAVE_CONFIG_H -I../include -I. -I../libmp3lame -I.. -O3 -fomit-frame-pointer -ffast-math -funroll-loops -fthread-jumps -malign-double 
-frerun-loop-opt -fgcse -fexpensive-optimizations -fmove-all-movables -fschedule-insns2 -freduce-all-givs -mpentiumpro -march=pentiumpro 
-mfancy-math-387 -Wall -c tabinit.c -Wp,-MD,.deps/tabinit.TPlo  -fPIC -DPIC -o .libs/tabinit.lo -save-temps -v

Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-94)
 /usr/lib/gcc-lib/i386-redhat-linux/2.96/cpp0 -lang-c -v -I../include -I. -I../libmp3lame -I.. -D__GNUC__=2 -D__GNUC_MINOR__=96 
-D__GNUC_PATCHLEVEL__=0 -D__ELF__ -Dunix -Dlinux -D__ELF__ -D__unix__ -D__linux__ -D__unix -D__linux -Asystem(posix) 
-D__OPTIMIZE__ -D__FAST_MATH__ -Wall -Acpu(i386) -Amachine(i386) -Di386 -D__i386 -D__i386__ -D__pentiumpro -D__pentiumpro__ 
-D__tune_pentiumpro__ -D__tune_pentiumpro__ -D__PIC__ -D__pic__ -DHAVE_CONFIG_H -DPIC -MD .deps/tabinit.TPlo tabinit.c tabinit.i
GNU CPP version 2.96 20000731 (Red Hat Linux 7.1 2.96-94) (cpplib) (i386 Linux/ELF)
ignoring nonexistent directory "/usr/i386-redhat-linux/include"
#include "..." search starts here:
#include <...> search starts here:
 ../include
 .
 ../libmp3lame
 ..
 /usr/local/include
 /usr/lib/gcc-lib/i386-redhat-linux/2.96/include
 /usr/include
End of search list.
 /usr/lib/gcc-lib/i386-redhat-linux/2.96/cc1 tabinit.i -mcpu=pentiumpro -quiet -dumpbase tabinit.c -malign-double -mpentiumpro -march=pentiumpro 
-mfancy-math-387 -O3 -Wall -version -fomit-frame-pointer -ffast-math -funroll-loops -fthread-jumps -frerun-loop-opt -fgcse -fexpensive-optimizations 
-fmove-all-movables -fschedule-insns2 -freduce-all-givs -fPIC -o tabinit.s
GNU C version 2.96 20000731 (Red Hat Linux 7.1 2.96-94) (i386-redhat-linux) compiled by GNU C version 2.96 20000731 (Red Hat Linux 7.1 
2.96-94).
tabinit.c: In function `make_decode_tables':
tabinit.c:122: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Comment 3 redhat-bugs2eran 2001-07-28 19:48:01 EDT
Created attachment 25289 [details]
tabinit.i  created by above
Comment 4 Richard Henderson 2004-10-01 19:07:06 EDT
Duplicate, but fortunately this version of the PR contains a test case
that allows me to verify that the problem does not exist in gcc 3.2.

*** This bug has been marked as a duplicate of 38131 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:48:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.