Bug 496047 - Enable VIA Padlock support on x86_64
Enable VIA Padlock support on x86_64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-16 05:27 EDT by Christian Bauer
Modified: 2009-10-05 03:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-05 01:03:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Bauer 2009-04-16 05:27:33 EDT
Description of problem:
Support for the VIA Padlock extensions (the padlock-aes and padlock-sha kernel modules) is missing from the x86_64 kernel packages. The VIA Nano processor supports both x86_64 and Padlock.
Comment 1 Chuck Ebbert 2009-04-16 20:49:34 EDT
That looks completely untested; the config rules prohibit building that module for x86_64.
Comment 2 Christian Bauer 2009-04-17 08:21:23 EDT
It appears that some patching is needed:
http://lkml.org/lkml/2009/3/14/55
http://lkml.org/lkml/2009/3/14/56
http://lkml.org/lkml/2009/3/14/54
Comment 3 Chuck Ebbert 2009-04-21 04:48:47 EDT
Patch 1/2 is already in 2.6.30-rc; patch 2/2 is queued for 2.6.30
Comment 4 Chuck Ebbert 2009-06-02 02:14:06 EDT
(In reply to comment #3)
> Patch 1/2 is already in 2.6.30-rc; patch 2/2 is queued for 2.6.30  

Hmm, patch 2/2 is not queued. I have built an F-11 test kernel locally with both patches applied.
Comment 5 Matt Domsch 2009-06-03 15:26:07 EDT
Could be interesting on Dell's DCS "Fortuna" server.
Comment 6 Chuck Ebbert 2009-06-04 00:54:20 EDT
I have all the patches applied to an F11 kernel -- it oopses when trying to mount an encrypted disk volume.

http://cebbert.fedorapeople.org/oops/

System: Samsung NC20, with BIOS 08MQ

$ cat /proc/cpuinfo
processor	: 0
vendor_id	: CentaurHauls
cpu family	: 6
model		: 15
model name	: VIA Nano processor U2250@1300+MHz
stepping	: 2
cpu MHz		: 1595.989
cache size	: 1024 KB
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush acpi mmx fxsr sse sse2 ss tm pbe syscall nx fxsr_opt rdtscp lm constant_tsc up rep_good pni est tm2 ssse3 cx16 xtpr rng rng_en ace ace_en ace2 phe phe_en lahf_lm
bogomips	: 3191.97
clflush size	: 64
cache_alignment	: 128
address sizes	: 36 bits physical, 48 bits virtual
Comment 7 Chuck Ebbert 2009-06-04 00:55:34 EDT
(In reply to comment #5)
> Could be interesting on Dell's DCS "Fortuna" server.  

Yes. Please send one. :)
Comment 8 Chuck Ebbert 2009-10-05 01:03:09 EDT
This is all fixed in Fedora 11, but due to the amount of code change it won't get backported. The random number generator is also enabled on 64-bit, the cpufreq driver works properly with ACPI P-states and the SD/MMC driver is there as well.
Comment 9 Christian Bauer 2009-10-05 03:35:57 EDT
Works for me, thanks!

Note You need to log in before you can comment on or make changes to this bug.