Bug 496057 - Anaconda (Install) doesn't use multipath tools information during install with option "mpath"
Anaconda (Install) doesn't use multipath tools information during install wit...
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All All
low Severity medium
: rc
: ---
Assigned To: Peter Jones
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-16 07:30 EDT by IBM Bug Proxy
Modified: 2010-11-09 08:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 22:31:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2009-04-16 07:30:32 EDT
=Comment: #0=================================================
Chandra S. Seetharaman <sekharan@us.ibm.com> - 
---Problem Description---
During install, Anaconda does use all relevant multipath information when installing with the
install option "mpath"
Contact Information = chandra.seetharaman@us.ibm.com 
 
---Additional Hardware Info---
DS4800 (IBM/1815) 

 ---uname output---
Linux elm3c241 2.6.18-128.el5 #1 SMP Wed Dec 17 11:58:23 EST 2008 ppc64 unknown
 
Machine Type = JS22 
 
---Debugger---
A debugger is not configured
 
---Steps to Reproduce---
 Try to install on a assymmetric multipathed device, like a DS4K or any alua storage (like IBM 2145)
or any storage for which the default path group policy in multipath tools is other than multibus.

During install one can break in to the shell and find the multipath configuration is made as
"multibus" which will send I/O round robin to all paths which will cause lot of delay during boot.

For a DS4K, (which has a path grouping policy as group_by_prio) folowing is the o/p of multipath -ll:

sh-3.2# multipath -ll
mapth2 () dm-2 IBM,1815      FAStT
[size=10G][features=0][hwhandler=0][rw]
\_round-robin 0 [prio=100][active]
 \_ 1:0:0:1 sdb 8:16  [active][ready]
 \_ 2:0:0:1 sdf 8:80  [active][ghost]
 
---Anaconda Component Data--- 
Userspace tool common name: multipath tools 
The userspace tool has the following bit modes: both 
Userspace rpm: multipath 
 
*Additional Instructions for chandra.seetharaman@us.ibm.com:
-Attach ltrace and strace of userspace application.
Comment 1 IBM Bug Proxy 2009-05-05 14:00:48 EDT
------- Comment From sekharan@us.ibm.com 2009-05-05 13:53 EDT-------
RedHat,

Any update on this bug ?
Comment 2 IBM Bug Proxy 2009-05-26 01:40:34 EDT
------- Comment From sharyath@in.ibm.com 2009-05-26 01:34 EDT-------
Red Hat
Any update on this bug
Thanks
Comment 3 Denise Dumas 2009-05-26 11:45:30 EDT
Hi,
This is proposed for 5.5, which has not yet opened for development.
When it opens, we will review all of the proposed bugzillas and ack or nak them.
Comment 4 IBM Bug Proxy 2009-06-04 03:00:29 EDT
------- Comment From sharyath@in.ibm.com 2009-06-04 02:56 EDT-------
Deferring it to RHEL 5.5
Comment 5 IBM Bug Proxy 2009-07-13 16:11:36 EDT
------- Comment From brking@us.ibm.com 2009-07-13 16:08 EDT-------
*** Bug 54649 has been marked as a duplicate of this bug. ***
Comment 6 IBM Bug Proxy 2009-07-29 19:10:28 EDT
------- Comment From sekharan@us.ibm.com 2009-07-29 19:02 EDT-------
Dear RedHat,

Can this problem be fixed in RHEL 6 ? (since it is a major release, it will be nice if we can have the "linux mpath" install work for all multipath devices).
Comment 7 IBM Bug Proxy 2009-11-03 04:31:27 EST
------- Comment From sharyath@in.ibm.com 2009-11-03 04:24 EDT-------
Red Hat
Any chances of it to be included in RHEL 6 or should we defer it to RHEL 5.5
Thanks
Comment 8 IBM Bug Proxy 2009-11-17 12:42:41 EST
------- Comment From sharyath@in.ibm.com 2009-11-17 12:30 EDT-------
RedHat
Any update on the request
Comment 9 Denise Dumas 2009-11-17 13:36:10 EST
Your best chance of getting this in is to submit a patch upstream, which we could then retrofit to RHEL6 and finally RHEL5 (although that multipath code base is significantly different so it would certainly not be a straight backport). But we're out of capacity ATM.
Comment 10 IBM Bug Proxy 2009-11-17 14:00:42 EST
------- Comment From sekharan@us.ibm.com 2009-11-17 13:51 EDT-------
What do you mean by upstream ? Fedora ?

Note that the code change needed is not in kernel, but in the install scripts.
Comment 11 Denise Dumas 2009-12-16 11:13:36 EST
In the upstream of whatever component you want to change. In this case, for the installer, Fedora is the upstream.
Comment 12 IBM Bug Proxy 2010-01-22 02:51:18 EST
------- Comment From sharyath@in.ibm.com 2010-01-22 02:43 EDT-------
Redhat
Do let me know how to proceed with this bug. We mirrored it to Red Hat Bugzilla thinking thats the right place. Do let us know what do you mean by Upstream in this case, as we thought by mirroring to Red Hat bugzilla we already have brought to the noticed of Fedora team.
Thanks
Sharyathi
Comment 13 IBM Bug Proxy 2010-02-03 01:41:10 EST
------- Comment From sharyath@in.ibm.com 2010-02-03 01:33 EDT-------
Red Hat
Team any updates
Comment 14 IBM Bug Proxy 2010-03-26 07:20:53 EDT
------- Comment From sharyath@in.ibm.com 2010-03-26 07:18 EDT-------
Red Hat
any update here
Comment 15 IBM Bug Proxy 2010-06-16 12:18:37 EDT
------- Comment From edpollar@linux.ibm.com 2010-06-16 11:58 EDT-------
reassigning qa....
Comment 16 David Cantrell 2010-07-01 22:31:06 EDT
This should be working under RHEL 6.  Marking this as CLOSED NEXTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.