This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 49614 - dma disk errors hangs hangs install
dma disk errors hangs hangs install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-21 12:20 EDT by Bill Faust
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-23 15:22:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Faust 2001-07-21 12:20:49 EDT
Description of Problem:
Installer hangs when installing packages with first error being "hda:
dma_intr: status=0x51" and then "hda: dma_intr: status: 0x84" as first two
errors.  Then a bunch of timout errors waiting on drive to come ready.

How Reproducible:
Every time.

Steps to Reproduce:
1. Boot from floppy "bootnet.img".
2. Perform FTP network install.
3. Will hang on one of the first few packages it installs as described
above.

Actual Results:
I get the error messages and installation program hangs forever.

Expected Results:
A nice clean install with a friendly "Thank you for installing RedHat 7.1!"

Additional Information:

I have five identical machines and the bug appears on all of them, so a
hardware problem is unlikely.  Also, all machines CAN load RedHat 6.2
correctly.  Problem appears in 7.1.

Motherboard: FIC SD-11
CPU: Athlon 600 MHz (Slot A)
Harddrive: Maxtor 8216002 (2 GB, 4465/15/63)
Ethernet Card: Some cheap NE2000 PCI
Video card: varied

Some of the things I have tried:

1. Updated BIOS to version NC611 (the latest)
2. Since the problem appeared to be with DMA, I tried boot options like:
   "linux ide=nodma"
   "linux hda=nodma ide=nodma"
   "linux hda=nodma ide=nodema floppy=nodma"
I thought it strange that it still gave the dma error even though I had
these kernel options specified.
3. Disabling all I could think to in the BIOS.  Unfortunately I could not
find a switch to disable DMA.

This bug report is similar to others I have found regarding DMA errors but
theirs did not seem as severe, as they were still able to install.
Comment 1 Brent Fox 2001-07-23 11:16:11 EDT
Changing component to the kernel.
Comment 2 Arjan van de Ven 2001-07-23 11:24:59 EDT
Any idea what chipset this is ?
And are the IDE disks connected to the chipset directly or
to some raid or otherwise special chip ?
Comment 3 Bill Faust 2001-07-23 15:22:41 EDT
Some more information.

1. I went back and tried RH 6.1 and also encountered disk read/write errors on
one of the two systems I am working through this problem with.  So likelihood
that his is hardware problem and not software bug has gone way up.

2. Chipset is AMD 751 North bridge and VIA 686A ("Super South") for South
bridge.

3. Had a typo on the drive type.  It is a Maxtor 82160D2.

4. There is a lot of information at
http://www.fic.com.tw/techsupport/faq/faqs01SD11.htm on this motherboard with
lots of comments about UDMA 66 problems with Maxtor drives (which I have).

5. I have five computers equipped with this motherboard and while pretty stable,
they have not been nearly as stable as other computers in our little computing
farm of 18 computers.  So maybe I am now just uncovering a long standing problem
with this motherboard/disk combination.

I am suspecting this really isn't a RedHat 7.1 problem right now with the
inability to load even RH 6.1 via bootnet.img.  Thanks for your prompt
attention.  I will read up on the FIC SD11 hardware issues and see if I can
debug it.  If you want to leave the bug report open then I promise to report
back, but I can understand if you want to close it.

Thanks, Bill Faust
Comment 4 Bill Faust 2001-07-27 11:36:04 EDT
Not a bug.  Definitely hardware problem with this motherboard (FIC SD11) and
UDMA harddrives.  It was an intermittant problem which led me to suspect RedHat
7.1.  On three different computers I replaced existing Maxtor 82160D2 harddrive
with non-UDMA drives: (QUANTUM BIGFOOT1280A on two and WDC AC11200L in the
third), and the problem went away.

Note You need to log in before you can comment on or make changes to this bug.