Bug 49616 - rc.sysinit still not robust enough in module configuration checks
rc.sysinit still not robust enough in module configuration checks
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-21 13:16 EDT by Michal Jaegermann
Modified: 2014-03-16 22:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-23 17:18:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-07-21 13:16:37 EDT
Description of Problem:

Lines like

if grep -q "options sound dmabuf=1" /etc/modules.conf ...

in /etc/rc.d/rc.sysinit are faulty because they will be found
even if this line is commented out but they will be missed if
white space is used in a different way.  To solve both problems
at the same time this should really read:

if modprobe -c | grep -q "options sound dmabuf=1" ....

OTOH lines with

if modprobe -c | egrep -s "<elaborate matching pattern>" ...

are really only waisting CPU cycles, especially if an output is
piped to 'awk', because:

   1) 'modprobe -c' normalizes white space in its output anyway
   2)  the whole job could be done in awk only and in a simpler
       manner.

Right now this looks like a close relative of a "dead cat".

P.S.  It _seems_ to me that I was already submitting in the past
a bug report like that. But I could not find any traces in my notes
nor while searching on bugzilla.  Maybe I only intended to?
Comment 1 Glen Foster 2001-07-23 17:17:58 EDT
This defect is considered SHOULD-FIX for Fairfax.
Comment 2 Bill Nottingham 2001-08-07 02:39:30 EDT
Should be fixed in initscripts-6.12-1.

Note You need to log in before you can comment on or make changes to this bug.