Bug 496163 - RHEL5 Support Request: Oracle in KVM
RHEL5 Support Request: Oracle in KVM
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
low Severity medium
: alpha
: ---
Assigned To: Jeffrey Needham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-16 17:48 EDT by Joshua Giles
Modified: 2013-01-09 16:34 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-04 12:55:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Giles 2009-04-16 17:48:43 EDT
Description of problem:
This bug will serve as a talking point for the Red Hat support implications of doing a "Oracle in KVM" certification.

Background
----------
Jeff Needham has filled a request for certification for Oracle single
instance 11g in KVM guests.

The permutation is PV guests, 64-bit only on a 64-bit Hypervisor with 11g single instance.

It is going to be that narrowly scoped so that we don't get killed with OCE
madness.

Every permutation out from this basic combo (like 32-bit hyper-visors and
32-bit guests) requires a complete OCE 11g run. OCEv3 (which only means 11g)
now includes specific tests for virtualization. There are a lot of
permutations.

We are confident that the request for support will be ignored. In parallel we can formally request KVM be elevated to "support" status (ESX has this status.)

Version-Release number of selected component (if applicable):
RHEL5.4

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
I didn't see Oracle as a partner in the "Parner" list so I chose BEA.
:)
Comment 1 Dor Laor 2009-05-20 15:39:22 EDT
Why do you think it is not working?
Who should be assigned to this bug? Devel/QE/Support/Marketing?
Comment 2 Jay Turner 2009-05-20 16:01:38 EDT
Dor, Josh isn't reporting a problem.  Just opening a ticket to track the process and progress of attempting an Oracle 11g OCE run in a KVM guest.
Comment 4 Joshua Giles 2009-05-21 10:51:16 EDT
I believe Jeff Needham should be assigned the bug temporarily as he is currently driving this with Oracle.

However, support/marketing/qe need to understand and agree on the implications of this request.

Not quite sure what component or product this should be assigned to if not kvm.  Perhaps this should be part of a "feature request" of the Oracle Certification effort...currently no way to track this in bz.  I'll look for an alternative.
Comment 5 Dor Laor 2009-06-04 12:55:41 EDT
(In reply to comment #4)
> I believe Jeff Needham should be assigned the bug temporarily as he is
> currently driving this with Oracle.
> 
> However, support/marketing/qe need to understand and agree on the implications
> of this request.
> 
> Not quite sure what component or product this should be assigned to if not kvm.
>  Perhaps this should be part of a "feature request" of the Oracle Certification
> effort...currently no way to track this in bz.  I'll look for an alternative.  

I strongly feel we need a requirement component in kvm.
Since we created an ieee test plan component.

In the mean time I close this bug
Comment 6 Jeffrey Needham 2009-07-07 16:19:35 EDT
I requested an update from Oracle kernel development.  The kit that enables VM environment certification is only available for 11gR2, and therefore, has not been released yet (nor has the 11gR2 RDBMS). If approved, then it will only be for KVM guests running 64-bit RDBMS non-RAC instances.
Comment 7 Joshua Giles 2009-07-07 17:11:45 EDT
Subhendu, can you help drive this request?

Note You need to log in before you can comment on or make changes to this bug.