Bug 496181 - LVMError in lvactivate
LVMError in lvactivate
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:943c0638960163815...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-16 23:24 EDT by Mike Wolf
Modified: 2009-04-21 21:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 21:13:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (76.49 KB, text/plain)
2009-04-16 23:24 EDT, Mike Wolf
no flags Details

  None (edit)
Description Mike Wolf 2009-04-16 23:24:30 EDT
The following was filed automatically by anaconda:
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 397, in lvactivate
    raise LVMError("lvactivate failed for %s" % lv_name)
  File "/usr/lib/anaconda/storage/devices.py", line 1960, in setup
    lvm.lvactivate(self.vg.name, self._name)
  File "/usr/lib/anaconda/storage/devices.py", line 584, in minSize
    self.setup()
  File "/usr/lib/anaconda/iw/partition_ui_helpers_gui.py", line 383, in createPreExistFSOptionSection
    reqlower = origrequest.minSize
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 491, in editLogicalVolume
    (row, self.fsoptionsDict) = createPreExistFSOptionSection(reallv, maintable, row, mountCombo, self.storage, ignorefs = ["mdmember", "lvmpv", "vfat"], luksdev=templuks)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 716, in editCurrentLogicalVolume
    self.editLogicalVolume(lv)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 747, in editLogicalVolumeCB
    self.editCurrentLogicalVolume()
LVMError: lvactivate failed for lv_root
Comment 1 Mike Wolf 2009-04-16 23:24:35 EDT
Created attachment 339956 [details]
Attached traceback automatically from anaconda.
Comment 2 Mike Wolf 2009-04-16 23:39:18 EDT
This may be a duplicate of Bug 495848, but I am no expert.  I was testing whether that bug could also be recreated from the F11 Spin1 LiveCD.  The exception occurred at the exact same step in the process as it did in the referenced bug, but I noticed that the tracebacks were different.  Anyway, here is the general process to reproduce this bug.

1.  Install F11 beta, and check the "Encrypt Disk" option.

2.  After successful install, boot from Spin1 LiveCD (we're going to install again).

3.  Start install from LiveCD.  Make sure you enter the passphrase for the encrypted drive.

4.  When you get to drive layout, select "Create Custom layout" and click "Next"

5.  Select /dev/sda2 and click "Edit". (This should be the device holding the current LVM)

6.  Click the "Format as:" box, and choose "physical volume (LVM)".  The
"Encrypt" checkbox should already be checked.  Leave it that way, and click
"OK".

7.  Under the volume group, select "lv_root" then click "Edit".

8.  When the "Edit LVM Volume Group" window pops up, select "lv_root" and click
"Edit".

9.  Crash!

Excpected behavior:  At step #5, a dialogue box should have popped up stating that you couldn't edit that device because it was part of a volume group.  This is what happens when drive was not previously encrypted.

Actual behavior:  At step #5, it lets you edit and format /dev/sda2.  These results in the exception being thrown after step 8.
Comment 3 Mike Wolf 2009-04-20 19:16:16 EDT
I just tried the boot.iso from the nightly build for 4-20-2009.  This bug is fixed as of anaconda 11.5.0.46-1, thanks!

Note You need to log in before you can comment on or make changes to this bug.