Bug 49621 - RFE: separate ipv6 support
Summary: RFE: separate ipv6 support
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xinetd   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-21 19:11 UTC by Pekka Savola
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-24 07:11:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2001-07-21 19:11:25 UTC
IPv6 support has been requested in #41309.

Unfortunately xinetd's ipv6 support hasn't been designed all that well (it fails on ipv4-only system, 
among other things), and patching it would take a _lot_ of work.

Therefore I propose to add xinetd-ipv6 subpackage with only /usr/sbin/xinetd-ipv6 binary inside,
same as /usr/sbin/xinetd except with ipv6 support.

In /etc/init.d/xinetd, if you have IPv6 enabled in configuration and the subpackage installed, then 
IPv6-compatible xinetd would be run.

This has been implemented in .src.rpm against 2.3.0-2 in http://www.netcore.fi/pekkas/linux/ipv6/.

Comment 1 Trond Eivind Glomsrxd 2001-07-23 22:52:03 UTC
Added in xinetd-2.3.0-3

Comment 2 Pekka Savola 2001-07-24 04:56:50 UTC
One note: if you have traditional xinetd running, then enable IPv6 and do '/sbin/service xinetd restart', the
script gets confused because it can't stop 'xinetd-ipv6'.  Going around this would be rather complicated
and might uglify the code, so I didn't go into it.  You might want to consider whether this is an acceptable 
approach.


Comment 3 Pekka Savola 2001-07-24 07:11:30 UTC
This can be fixed by a dirty trick (also fixes status) -- reopening just in
case.

--- xinetd.init.orig    Tue Jul 24 10:10:55 2001
+++ xinetd.init Tue Jul 24 10:11:21 2001
@@ -67,7 +67,7 @@
     
 stop(){
     echo -n $"Stopping $prog: "
-    killproc $prog
+    killproc xinetd
     RETVAL=$?
     echo
     rm -f /var/lock/subsys/xinetd
@@ -77,7 +77,7 @@
        
 reload(){
     echo -n $"Reloading configuration: "
-    killproc $prog -USR2
+    killproc xinetd -USR2
     RETVAL=$?
     echo
     return $RETVAL
@@ -103,7 +103,7 @@
        stop
        ;;
     status)
-       status xinetd
+       status $prog
        ;;
     restart)
        restart



Comment 4 Trond Eivind Glomsrxd 2001-08-10 19:49:54 UTC
Fixed in xinetd-2.3.0-4 and newer


Note You need to log in before you can comment on or make changes to this bug.