Bug 496214 - About Spacewalk link shown on .pxt ISE - 500 page
About Spacewalk link shown on .pxt ISE - 500 page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Devan Goodwin
Steve Salevan
:
: 493695 (view as bug list)
Depends On:
Blocks: 463876
  Show dependency treegraph
 
Reported: 2009-04-17 06:41 EDT by Jan Pazdziora
Modified: 2009-09-10 14:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:54:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (57.41 KB, image/png)
2009-04-17 06:41 EDT, Jan Pazdziora
no flags Details

  None (edit)
Description Jan Pazdziora 2009-04-17 06:41:31 EDT
Created attachment 339983 [details]
Screenshot

Description of problem:

I managed to get an ISE - 500 page. The cause of the ISE is not really important. On the page thou, there was a link "About Spacewalk". That is probably not right, provided this was Satellite 5.3.0 installation.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090403.2 on i386.

How reproducible:

Seen once.

Steps to Reproduce:
1. Manage to get ISE on .pxt page, like on /network/monitoring/scout/index.pxt.
2. Look at the grey menu bar.
  
Actual results:

About Spacewalk

Expected results:

About RHN Satellite would be more appropriate.

Additional info:

The link points to /help/about.pxt which has About RHN Satellite title in the page content (next to the blue circle with white i), yet the About Spacewalk is even in this menu. And the <title> says "RHN Satellite - About Spacewalk".
Comment 1 Devan Goodwin 2009-04-21 09:39:28 EDT
Problem can be reproduced by just logging out and going straight to /help/about.pxt, here you will see the "About Spacewalk" tab both on the top navigation bar and on the left hand side of the screen.

Because this string is originating from a pxt XML file we cannot easily substitute it out with a macro, it would likely have to be moved to the branding RPM for both Satellite and Spacewalk. 

In the Java stack this link was changed to simply "About" as you can see on the login page at: /rhn/Login.do, so will do the same for this instance in the Perl stack to be consistent.


Committed to spacewalk.git d408f48b3022488ff23717216faf4a691a838f03.
Ported to satellite.git in 0ccbcf5cbc712c974eff4605c7e3bf5384300557
Comment 2 Devan Goodwin 2009-04-21 15:36:10 EDT
*** Bug 493695 has been marked as a duplicate of this bug. ***
Comment 3 Steve Salevan 2009-04-30 16:12:55 EDT
Generated an ISE on a PXT page and visited /help/about.pxt, all references to Spacewalk were removed and replaced with "RHN Satellite".  Moving to VERIFIED, tested on 4/24 ISO.
Comment 4 Milan Zazrivec 2009-08-09 12:01:28 EDT
Verified in stage -> RELEASE_PENDING.
Comment 5 Brandon Perkins 2009-09-10 14:54:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.