Bug 496257 - F11 Beta: anaconda cannot find kickstart file on hard disk whereas F10 does.
F11 Beta: anaconda cannot find kickstart file on hard disk whereas F10 does.
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 10:48 EDT by Gerry Reno
Modified: 2010-01-20 13:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-20 13:48:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (34.66 KB, text/plain)
2009-04-18 20:05 EDT, Gerry Reno
no flags Details
anaconda.syslog (51.98 KB, text/plain)
2009-04-18 20:10 EDT, Gerry Reno
no flags Details

  None (edit)
Description Gerry Reno 2009-04-17 10:48:34 EDT
Description of problem:
Instead of playing the guessing game of where the usbkey is located.  I put the kickstart file back on the hard drive.  F11 Beta cannot find this file but F10 has no problem finding this file.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. create kickstart file and put on hard drive
2. pass location of kickstart file on kernel line
3. boot kernel
  
Actual results:
F11 Beta: cannot find kickstart file on hard drive
F10: finds the kickstart file.

Expected results:
finds the kickstart file

Additional info:

ks=hd:sdd1:/upgrade/ks.cfg
Comment 1 Chris Lumens 2009-04-17 11:17:32 EDT
Are you positive that the USB drive is sdd1 when you do the install?  Remember that device names are not guaranteed to be stable between reboots.  Does using LABEL=<whatever> or UUID=<whatever> instead of sdd1 work better?
Comment 2 Gerry Reno 2009-04-17 11:56:59 EDT
We didn't use the usbkey here.  sdd1 is the /boot partition where we had placed the kickstart file in /boot/upgrade/ks.cfg.  I'll try this using UUID.
Comment 3 Gerry Reno 2009-04-17 12:09:32 EDT
I tried it like this:

ks=hd:LABEL=/boot:/upgrade/ks.cfg

and 

ks=hd:UUID=<big id went here>:/upgrade/ks.cfg

and both of these failed as well.
Comment 4 Gerry Reno 2009-04-17 13:07:59 EDT
I tried this just now from the rawhide boot.iso and it fails exactly the same there as well.
Comment 5 Gerry Reno 2009-04-17 14:03:15 EDT
I tested the x86_64 rawhide boot.iso to be exact.
Comment 6 Gerry Reno 2009-04-18 20:05:17 EDT
Created attachment 340189 [details]
anaconda.log

Log for latest attempts
Comment 7 Gerry Reno 2009-04-18 20:10:34 EDT
Created attachment 340190 [details]
anaconda.syslog

Log of latest attempts
Comment 8 Gerry Reno 2009-04-18 20:14:38 EDT
Comment on attachment 340190 [details]
anaconda.syslog

Ok, ignore these logs.  Judging from the timestamps on them they are from a year ago when the machine was still on F9.
Comment 9 Gerry Reno 2009-04-18 20:18:06 EDT
I cannot find any other anaconda logs on the machine so maybe it isn't logging right with F10, F11-beta or the boot.iso disks.
Comment 10 Gerry Reno 2009-05-04 02:40:08 EDT
This problem is still happening with both regular anaconda and with preupgrade.  Whenever you try to pass the location of the kickstart file on the kernel line, anaconda refuses to find the file.
Comment 11 Chris Lumens 2009-06-08 15:41:17 EDT
Is it possible you're passing too much stuff on your kernel command line, so the location of the kickstart file is getting trimmed down to something that doesn't work?
Comment 12 Bug Zapper 2009-06-09 10:00:26 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Gerry Reno 2009-06-09 13:03:03 EDT
Chris,
 No, there's very little on the line except for the kickstart.  Just root= and quiet rhgb.  Even when you tried to edit the line in the anaconda screen, it still would not find the file.
Comment 14 Chris Lumens 2009-07-28 17:06:51 EDT
I just saw this on a very different setup from what you're doing.  I noticed that if I hit enter at the early dialog to change the kickstart location, it worked.  This was reliably reproducable - it wouldn't find the kickstart file on USB the first time, but did after enter was hit.

Does this match up with what you're seeing?

Note You need to log in before you can comment on or make changes to this bug.