Bug 496268 - adding packages to errata, *sometimes* returns ise
adding packages to errata, *sometimes* returns ise
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
https://dhcp77-141.rhndev.redhat.com/...
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-04-17 11:21 EDT by wes hayutin
Modified: 2009-08-26 04:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 14:43:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-04-17 11:21:16 EDT
Description of problem:

4/14 rhel4 server


recreate:
1. create custom channel
2. create errata
3. add package to errata
4. remove package from errata
5. add same package to errata

I'm not always able to recreate this bug...


The following exception occurred while executing this request:
POST /rhn/errata/manage/AddPackages.do

Date:4/17/09 11:02:18 AM EDT
Headers:
  host: dhcp77-141.rhndev.redhat.com
  user-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092416 Firefox/3.0.3
  accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  accept-language: en-us,en;q=0.5
  accept-encoding: gzip,deflate
  accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Keep-Alive: 300
  connection: keep-alive
  referer: https://dhcp77-141.rhndev.redhat.com/rhn/errata/manage/AddPackages.do
  cookie: JSESSIONID=282A12B63B9842D1766ACF259985321E; pxt-session-cookie=4102x7988a212b3d089999662f9091605a489
  content-type: application/x-www-form-urlencoded
  content-length: 589

Request:
Local Name = dhcp77-141.rhndev.redhat.com
Server Name = dhcp77-141.rhndev.redhat.com
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@575b575b[session=StandardSession[282A12B63B9842D1766ACF259985321E]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, javax.servlet.jsp.jstl.fmt.timeZone.request, org.apache.struts.action.MESSAGE, parentUrl, org.apache.struts.action.MODULE, __sitemesh__filterapplied, session, org.apache.struts.action.mapping.instance, list_1154021400_selected_amt, requestedUri, 

Form Variables:
  eid: 5601
  list_1154021400_sel: 18261
  1154021400_PAGE_SIZE_LABEL_SELECTED: null
  list_1154021400_items: 18261
  list_1154021400_filterclass: com.redhat.rhn.frontend.taglibs.list.ColumnFilter
  view_channel: any_channel
  list_1154021400_sel_all: on
  list_1154021400_oldfilterval: testAutoFile-2
  dispatch: Add Packages
  list_1154021400_filterattr: packageNvre
  list_1154021400_none: false
  submitted: true
  list_1154021400_filterby: Package 
  list_1154021400_filterval: testAutoFile-2
  list_1154021400_all: false
  1154021400_PAGE_SIZE_LABEL: 25


User Information:
User admin (id 1, org_id 1)

Exception:
javax.servlet.ServletException: ORA-00001: unique constraint (RHNSAT.RHN_SET_USER_LABEL_ELEM_UNQ) violated

        at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)
        at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
        at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:432)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
        at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)
        at java.lang.Thread.run(Thread.java:735)
Caused by: com.redhat.rhn.common.db.ConstraintViolationException: ORA-00001: unique constraint (RHNSAT.RHN_SET_USER_LABEL_ELEM_UNQ) violated

        at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
        at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:331)
        at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:288)
        at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:745)
        at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:219)
        at oracle.jdbc.driver.T4CPreparedStatement.executeForRows(T4CPreparedStatement.java:970)
        at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1190)
        at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:3370)
        at oracle.jdbc.driver.OraclePreparedStatement.execute(OraclePreparedStatement.java:3476)
        at com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.execute(NewProxyPreparedStatement.java:1908)
        at com.redhat.rhn.common.db.NamedPreparedStatement.execute(NamedPreparedStatement.java:137)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:454)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:431)
        at com.redhat.rhn.common.db.datasource.CachedStatement.executeUpdate(CachedStatement.java:269)
        at com.redhat.rhn.common.db.datasource.WriteMode.executeUpdate(WriteMode.java:33)
        at com.redhat.rhn.domain.rhnset.RhnSetFactory.executeMode(RhnSetFactory.java:166)
        at com.redhat.rhn.domain.rhnset.RhnSetFactory.save(RhnSetFactory.java:145)
        at com.redhat.rhn.manager.rhnset.RhnSetManager.store(RhnSetManager.java:88)
        at com.redhat.rhn.frontend.struts.BaseSetHelper.storeSet(BaseSetHelper.java:251)
        at com.redhat.rhn.frontend.struts.BaseSetHelper.updateSet(BaseSetHelper.java:153)
        at com.redhat.rhn.frontend.taglibs.list.helper.ListRhnSetHelper.update(ListRhnSetHelper.java:170)
        at com.redhat.rhn.frontend.taglibs.list.helper.ListSetHelper.execute(ListSetHelper.java:145)
        at com.redhat.rhn.frontend.taglibs.list.helper.ListRhnSetHelper.execute(ListRhnSetHelper.java:47)
        at com.redhat.rhn.frontend.action.errata.AddPackagesAction.execute(AddPackagesAction.java:83)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
        ... 40 more
Caused by: java.sql.SQLException: ORA-00001: unique constraint (RHNSAT.RHN_SET_USER_LABEL_ELEM_UNQ) violated

        ... 65 more
Comment 1 Justin Sherrill 2009-04-22 16:52:34 EDT
Hey wes, i'm not able to reproduce this.  Are you still able to?  Any pointers?
Comment 2 wes hayutin 2009-04-23 14:43:42 EDT
cant reproduce either.. closing

Note You need to log in before you can comment on or make changes to this bug.