Bug 496309 - preupgrade makes boot menu disappear
preupgrade makes boot menu disappear
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 14:21 EDT by Ray Todd Stevens
Modified: 2014-01-21 18:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 14:35:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2009-04-17 14:21:18 EDT
This may or may not be a bug.  I think it is, but it might be a purposeful choice.   Either way it is causing operational problems.

First I am experiencing other problems with preupgrade which are being filed under other bugs or I might not have noticed this issue.   The problem is that normally when you boot the server you get the option to press space bar to get a menu from which you can boot other kernels, or change parameters.   I have run preupgrade and not instead I get a message about booting from cd/dvd and then it goes on.  If you press the reboot button on preupgrade to then it reboots and goes into the upgrade routine.

If the upgrade fails and you want to try again, or of you exit preupgrade and plan to reboot and then run preupgrade this will not work because of the no menu.   

Now I also don't have access to old kernels or switching to single user mode.
Comment 1 Will Woods 2009-04-17 14:35:52 EDT
preupgrade does not change your grub configuration.

It uses grub's '--once' flag to cause your system to boot directly into the upgrade when you hit the 'reboot' button, but this only happens once.

When you reboot again your menu will appear as it did before.
Comment 2 Ray Todd Stevens 2009-04-17 14:49:17 EDT
That is my point when I reboot again the menu is now gone.   It was there before I ran preupgrade, like maybe 1-2 hours earlier.   At that time I took the system time, used the menu to boot into single user mode and did a fsck.   I find this a wise precaution before an upgrade.   Now the menu is gone.

So something happened.
Comment 3 Ray Todd Stevens 2009-04-17 14:50:53 EDT
Also this boot from cd/dvd message is new, and no there is not a disk in the drive I checked.
Comment 4 Ray Todd Stevens 2009-04-17 14:57:12 EDT
OK I found the problem.   What happened is a better question.   The timeout= value in grub.conf had been changed to 0.   Changing it back fixes the problem.   Now I guess the question is what changed it??????

Note You need to log in before you can comment on or make changes to this bug.