Bug 496316 - Unusable video with xorg-x11-drv-intel-2.7.0-1
Unusable video with xorg-x11-drv-intel-2.7.0-1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 14:51 EDT by Mace Moneta
Modified: 2009-04-20 18:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 18:19:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo of the GDM login screen (752.57 KB, image/jpeg)
2009-04-17 14:52 EDT, Mace Moneta
no flags Details
Xorg.0.log of UXA (62.98 KB, text/plain)
2009-04-17 15:00 EDT, Mace Moneta
no flags Details
Xorg.0.log from my notebook (X3100 graphics) (32.35 KB, text/plain)
2009-04-17 18:38 EDT, James
no flags Details

  None (edit)
Description Mace Moneta 2009-04-17 14:51:54 EDT
Description of problem:

I upgraded today to:

xorg-x11-drv-intel-2.7.0-1.fc11.x86_64.rpm
kernel-2.6.29.1-95.fc11.x86_64.rpm

in the hopes that some of the KMS+UXA issues were resolved.  However, the resulting video (both without an xorg.conf, or with a minimal xorg.conf specifying 1920x1200 resolution) is unusable.  It appears to be interlaced and shifted (see the attached photo of the login screen).  The initial plymouth graphic is displayed correctly, but as soon as GDM displays the login screen the video is out.  I logged in anyway, and the screen stays in this unusable mode.  The monitor reports that it is operating at the correct resolution (1920x1200@60).

Version-Release number of selected component (if applicable):

xorg-x11-drv-intel-2.7.0-1.fc11.x86_64.rpm

How reproducible:

Always

Steps to Reproduce:
1.Install xorg-x11-drv-intel-2.7.0-1.fc11.x86_64.rpm
2.Install kernel-2.6.29.1-95.fc11.x86_64.rpm
3.Remove /etc/xorg.conf and 'nomodeset' from /etc/grub.conf
4.Restart
  
Actual results:

Unusable interlaced screen

Expected results:

Beautiful KMS+UXA nirvana

Additional info: Display native resolution is 1920x1200@60.  Adding 'nomodeset' to /etc/grub.conf, and creating an xorg.conf that does not specify UXA provides normal (EXA) operation.
Comment 1 Mace Moneta 2009-04-17 14:52:44 EDT
Created attachment 340068 [details]
Photo of the GDM login screen
Comment 2 Mace Moneta 2009-04-17 15:00:19 EDT
Created attachment 340071 [details]
Xorg.0.log of UXA
Comment 3 James 2009-04-17 18:38:49 EDT
Created attachment 340106 [details]
Xorg.0.log from my notebook (X3100 graphics)

Seen here too on X3100 graphics with this driver.
Comment 4 Warren Togami 2009-04-19 02:40:10 EDT
http://kojipkgs.fedoraproject.org/packages/kernel/2.6.29.1/
Any better with kernel -100+?
Comment 5 Mace Moneta 2009-04-19 16:21:50 EDT
Just upgraded to:

xorg-x11-drv-intel-2.7.0-1.fc11.x86_64
kernel-2.6.29.1-100.fc11.x86_64

Yes, the problem is resolved, at least for my G45/X4500HD.
Comment 6 Mace Moneta 2009-04-19 16:55:58 EDT
Unfortunately, KMS+UXA is still unstable on G45/X4500HD.  That's a different bug though (Bug 496516).
Comment 7 Peter Gordon 2009-04-19 16:56:58 EDT
I upgraded to today's rawhide including xorg-x11-drv-intel-2.7.0-1.fc11 and kernel-2.6.29.1-100.fc11; and the problem does indeed appear to be fixed.
Comment 8 Adam Jackson 2009-04-20 18:19:49 EDT
Yeah, fixed in rawhide, closing.

Note You need to log in before you can comment on or make changes to this bug.