Bug 496325 - rhel4 packages marked for update @ the same level on client
rhel4 packages marked for update @ the same level on client
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
wes hayutin
http://grandprix.rhndev.redhat.com/rh...
:
Depends On:
Blocks: 471789
  Show dependency treegraph
 
Reported: 2009-04-17 16:27 EDT by wes hayutin
Modified: 2009-09-10 14:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:44:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-04-17 16:27:20 EDT
Description of problem:

4/14 build rhel 5

sdc software packages update
lists the following

 	  libpng-1.2.7-3.el4_7.2:2   	  	
	ntp-4.2.0.a.20040617-8.el4_7.1


after full update via the webui.. the above updates are still listed

D: getObsoletes Fetched via: diskcache
D: obsoletesList is :  [['nocpulse-common', '2.1.8', '1.el4sat', '', 'noarch', 'NPusers', '1.17.50-1', '10'], ['nocpulse-common', '2.1.8', '1.el4sat', '', 'noarch', 'np-config', '2.110.50-1', '10'], ['nocpulse-common', '2.1.8', '1.el4sat', '', 'noarch', 'ConfigPusher-general', '1.3.0', '2'], ['nocpulse-common', '2.1.8', '1.el4sat', '', 'noarch', 'nslogs', '2.3.0', '2'], ['rhns-certs-tools', '5.2.0', '4.el4', '', 'noarch', 'rhns-certs', '', '0'], ['spacewalk-certs-tools', '0.5.5', '3.el4sat', '', 'noarch', 'rhns-certs-tools', '5.3.0', '2'], ['spacewalk-certs-tools', '0.5.5', '3.el4sat', '', 'noarch', 'rhns-certs', '5.3.0', '2'], ['spacewalk-ssl-cert-check', '1.7', '1.el4sat', '', 'noarch', 'rhn-ssl-cert-check', '1.7', '2']]
D: add instance class name up2date
D: Candidates for the selected list: [['libpng', '1.2.7', '3.el4_7.2', '2', 'i386', '159047', 'rhel-i386-as-4']]
D: Adding to transaction set ['libpng', '1.2.7', '3.el4_7.2', '2', 'i386', '159047', 'rhel-i386-as-4']
D: Checking for dependencies
D: Running transaction (final step)...
D: Sending back response (26, 'Failed: There was a package conflict error with the package set: RPM package conflict error.  The message was:\nTest install failed because of package conflicts:\npackage libpng-1.2.7-3.el4_7.2 is already installed\n', {'version': '0', 'package_conflicts': [('package libpng-1.2.7-3.el4_7.2 is already installed', [2, '', 0])], 'name': 'packages.update.package_conflicts'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: Called refresh_rpmlist
D: local action status:  (0, 'rpmlist refr
Comment 1 wes hayutin 2009-04-17 16:29:19 EDT
[root@fjs-0-12 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux AS release 4 (Nahant Update 7)
[root@fjs-0-12 ~]# 


recreate:

1. provision rhel 4_u7 client
2. run update on all errata
3. some kernel stuff fails.
4. remove kernel from skiplist on client
5. rerun errata update..


two packages remain, listed above w/ the above error on client
Comment 2 wes hayutin 2009-04-17 16:32:19 EDT
recreated on both fjs-0-12 and fjs-0-18

step 5, rerun pkg update..
pkgs installed but still listed as updates
Comment 3 Preethi Thomas 2009-04-20 14:54:45 EDT
Looks like packages installed from ui are still listed as updates.
1. provision rhel4u7 client.
2. register it to satellite
3. go to SDC-> Software->Packages->Install.
4. Select the first 2 packages and
5. Schedule the install of the packages.
6. run rhn_check -vvv
7.notice that packages are successfully installed
8. go back to SDC->Packages->List/Remove 
9. Notice that the 2 packages are listed in the list
10 Now go to SDC->Software->Packages->Install
Comment 4 Brad Buckingham 2009-05-07 17:17:28 EDT
After investigating using the latest code from git, these issues appear to already be resolved (i.e. not able to reproduce).

It appears that:

- the description, comment #1 and comment #2 related to errata/upgrades are likely addressed by the fix that was implemented with bug 498273 (modified 2009-05-06 13:50:03 EDT)

- comment #3 related package installs appears to be a duplicate of bug 498295 (modified 2009-05-04 18:17:40)

Since there have been multiple issues found in this area, I'm going to move this bugzilla to modified and then to on_qa so that it can go through verification, just in case this isn't a duplicate of the others.
Comment 5 wes hayutin 2009-05-11 10:44:42 EDT
verified 5/7.1
Comment 7 Brandon Perkins 2009-09-10 14:44:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.