Bug 496344 - Renewal: Missing information in the first 6 requests in the CA request queue.
Renewal: Missing information in the first 6 requests in the CA request queue.
Status: CLOSED ERRATA
Product: Dogtag Certificate System
Classification: Community
Component: CA (Show other bugs)
unspecified
All Linux
high Severity medium
: ---
: ---
Assigned To: Ade Lee
Chandrasekar Kannan
:
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2009-04-17 18:14 EDT by Andrew Wnuk
Modified: 2015-01-05 20:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 19:34:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix (3.53 KB, patch)
2009-04-28 17:23 EDT, Ade Lee
no flags Details | Diff
screen shot (188.09 KB, image/png)
2009-06-04 16:27 EDT, Jenny Galipeau
no flags Details

  None (edit)
Description Andrew Wnuk 2009-04-17 18:14:13 EDT
The first 6 requests seems to be missing information.
Request preview reports:
1. Certificate Pretty Print: null
2. Certificate Base-64 Encoded: null
3. Requestor Host: null
4. Approved By: null

see:
  https://<hostname>:9443/ca/agent/ca/profileReview?requestId=1
  . . .
  https://<hostname>:9443/ca/agent/ca/profileReview?requestId=6
Comment 1 Ade Lee 2009-04-28 17:23:18 EDT
Created attachment 341655 [details]
patch to fix

straight forward - just include the info in hand-crafted requests.

awnuk, please review
Comment 2 Andrew Wnuk 2009-04-28 20:18:27 EDT
attachment (id=341655) +awnuk
Comment 3 Ade Lee 2009-04-28 20:52:19 EDT
[builder@dhcp231-124 dogtag-src]$ svn ci -m "Bugzilla Bug #496334 -  Renewal: Missing information in the first 6 requests in the CA request queue." pki
Sending        pki/base/common/src/com/netscape/cms/servlet/csadmin/CertUtil.java
Sending        pki/dogtag/common/pki-common.spec
Transmitting file data ..
Committed revision 420.
Comment 4 Kashyap Chamarthy 2009-06-04 08:42:54 EDT
Hi, 
Was this error experienced only when a certificate was renewed?
I'm trying to verify this bug.
Comment 5 Kashyap Chamarthy 2009-06-04 08:46:01 EDT
More info:

I tried this

 https://pkiserv.pnq.redhat.com:9443/ca/agent/ca/profileReview?requestId=1

to

 https://pkiserv.pnq.redhat.com:9443/ca/agent/ca/profileReview?requestId=6

I still see 

Requestor Host - null
Comment 6 Jenny Galipeau 2009-06-04 16:27:50 EDT
Created attachment 346586 [details]
screen shot
Comment 7 Jenny Galipeau 2009-06-04 16:28:30 EDT
first 6 requests still missing requestor host.  See attached screenshot.
Comment 8 Ade Lee 2009-06-05 12:09:13 EDT
in the screen shot, requestor host is set to "" -- the empty string 
as opposed to null.

This is as expected - and is fine.
Comment 9 Jenny Galipeau 2009-06-05 12:22:22 EDT
Thanks Closing bug verified.

Note You need to log in before you can comment on or make changes to this bug.