Bug 496360 - RFE: Focus to text box after clicking Available
RFE: Focus to text box after clicking Available
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 22:28 EDT by Joshua Wulf
Modified: 2014-10-19 18:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-10 04:17:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2009-04-17 22:28:24 EDT
Description of problem: Yumex defaults to the Updates view when opened. My usual workflow is to click on Available, then type in the name of some package. However, after clicking on Available the focus stays with the checkbox, requiring me to go back to the mouse and click in the text box.

It would be good if after clicking on Available focus were to switch automatically to the text box so that the user can start typing immediately, without having to click there.
Comment 1 Tim Lauridsen 2009-08-06 06:53:56 EDT
This is fixed in the Yumex NextGen

You can try the latest test build here.

http://timlau.fedorapeople.org/files/yumex/
Comment 2 Joshua Wulf 2009-08-06 19:42:20 EDT
I installed yumex-2.9.0-0.9.pre.fc11.noarch


It looks great, and it does what I expect when I click on installed and updates. However, on the "available" tab focus still doesn't automatically go to the text input.
Comment 3 Joshua Wulf 2009-08-06 19:55:56 EDT
Another thing just happened.

I selected all the available updates and clicked apply.

I then got a depsolving issue for one of the packages, libyaz.

I went to the queue and deselected libyaz, then clicked apply again. I again got the error for libyaz.

It seems that either it didn't deselect libyaz, or else it deselected everything *except* libyaz.
Comment 4 Tim Lauridsen 2009-08-07 05:34:38 EDT
(In reply to comment #2)
> I installed yumex-2.9.0-0.9.pre.fc11.noarch
> 
> 
> It looks great, and it does what I expect when I click on installed and
> updates. However, on the "available" tab focus still doesn't automatically go
> to the text input.  

I could reproduce that and have fixed it upstream. Thanks for testing.

I will look into the deselection issue.
Comment 5 Tim Lauridsen 2009-08-07 06:29:31 EDT
Ok, I could reproduce the issue, i have fixed it too

new test release here:

http://timlau.fedorapeople.org/files/yumex/
Comment 6 Joshua Wulf 2009-08-09 19:37:12 EDT
This one works for me - both issues fixed.

Note You need to log in before you can comment on or make changes to this bug.