Bug 496387 - can't downgrade packages
can't downgrade packages
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-18 10:26 EDT by Michal Schmidt
Modified: 2014-01-21 18:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-18 15:28:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2009-04-18 10:26:25 EDT
Description of problem:
There does not seem to be any working way to downgrade a package using yum (I know I can use 'rpm -U --oldpackage ...', but I'd rather use yum directly).

I tried two methods: using yum-allowdowngrade and using yum shell
None worked.


Example of using yum-allowdowngrade:

[root@vF10 ~]# rpm -q icecream
icecream-0.9.3-6.fc10.x86_64
[root@vF10 ~]# yum list --showduplicates icecream
Loaded plugins: allowdowngrade, changelog, refresh-packagekit, remove-with-
              : leaves
Installed Packages
icecream.x86_64             0.9.3-6.fc10                         installed      
Available Packages
icecream.i386               0.8.0-11.20080117svn.fc9             fedora         
icecream.x86_64             0.8.0-11.20080117svn.fc9             fedora         
icecream.i386               0.9.3-6.fc10                         updates-testing
icecream.x86_64             0.9.3-6.fc10                         updates-testing
[root@vF10 ~]# yum --allow-downgrade install icecream-0.8.0
Loaded plugins: allowdowngrade, changelog, refresh-packagekit, remove-with-
              : leaves
Setting up Install Process
Parsing package install arguments
Package matching icecream-0.8.0-11.20080117svn.fc9.x86_64 already installed. Checking for update.
Nothing to do


Example of using yum shell:

[root@vF10 ~]# yum shell
Loaded plugins: allowdowngrade, changelog, refresh-packagekit, remove-with-
              : leaves
Setting up Yum Shell
> remove icecream-0.9.3
Setting up Remove Process
> install icecream-0.8.0
Setting up Install Process
Parsing package install arguments
Package matching icecream-0.8.0-11.20080117svn.fc9.x86_64 already installed. Checking for update.
> run
--> Running transaction check
---> Package icecream.x86_64 0:0.9.3-6.fc10 set to be erased
--> Finished Dependency Resolution

================================================================================
 Package          Arch           Version                Repository         Size
================================================================================
Removing:
 icecream         x86_64         0.9.3-6.fc10           installed         1.2 M

Transaction Summary
================================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove       1 Package(s)         


Version-Release number of selected component (if applicable):
yum-3.2.21-2.fc10.noarch
yum-utils-1.1.19-1.fc10.noarch
yum-allowdowngrade-1.1.19-1.fc10.noarch
rpm-4.6.0-2.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
follow the two examples
  
Actual results:
yum never replaces the package with the specified older version.

Expected results:
At least with yum-allowdowngrade yum should be able to downgrade the package.
Comment 1 James Antill 2009-04-18 15:28:15 EDT
 This is known, we fixed it by putting the downgrade functionality into core yum upstream. When a post 3.2.22 yum makes it back into F-10, it'll work (and obsolete the broken plugin).

Note You need to log in before you can comment on or make changes to this bug.