Bug 496420 - In F11 beta installer, checked the Rawhide repo. At first it wouldn't connect, immediately saying "Retrying download." After waiting a while I got the unhandled exception.
In F11 beta installer, checked the Rawhide repo. At first it wouldn't connect...
Status: CLOSED DUPLICATE of bug 493537
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:3049ea743f5f14d00...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-18 20:25 EDT by John Koelndorfer
Modified: 2009-04-20 10:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 10:42:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (151.31 KB, text/plain)
2009-04-18 20:26 EDT, John Koelndorfer
no flags Details

  None (edit)
Description John Koelndorfer 2009-04-18 20:25:55 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/image.py", line 290, in unmountCD
    % (dev.path,))
  File "/usr/lib/anaconda/yuminstall.py", line 694, in mirrorFailureCB
    unmountCD(self.tree, self.anaconda.intf.messageWindow)
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 301, in _failure
    action = cb(cb_obj, *args, **kwargs) or {}
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 406, in _mirror_try
    self._failure(gr, obj)
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 412, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 781, in _getFile
    http_headers=headers,
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 935, in _getFileRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1154, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1308, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1324, in _loadRepoXML
    return self._groupLoadRepoXML(text, ["primary"])
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1334, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1342, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1179, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 220, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 162, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 259, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 488, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 464, in doSackSetup
    return self._getSacks(archlist=archlist, thisrepo=thisrepo)
  File "/usr/lib/anaconda/yuminstall.py", line 1076, in <lambda>
    self.__withFuncDo(anaconda, lambda r: self.ayum.doSackSetup(thisrepo=r.id),
  File "/usr/lib/anaconda/yuminstall.py", line 1103, in __withFuncDo
    fn(repo)
  File "/usr/lib/anaconda/yuminstall.py", line 1077, in doSackSetup
    thisrepo=thisrepo, fatalerrors=fatalerrors)
  File "/usr/lib/anaconda/iw/task_gui.py", line 45, in setupRepo
    anaconda.backend.doSackSetup(anaconda, thisrepo=repo.id, fatalerrors=False)
  File "/usr/lib/anaconda/iw/task_gui.py", line 543, in _repoToggled
    if not setupRepo(self.anaconda, repo):
AttributeError: 'str' object has no attribute 'path'
Comment 1 John Koelndorfer 2009-04-18 20:26:00 EDT
Created attachment 340193 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-04-20 10:42:14 EDT

*** This bug has been marked as a duplicate of bug 493537 ***

Note You need to log in before you can comment on or make changes to this bug.