This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 49644 - rawhide SRPM nmap-2.54BETA22-2.src.rpm does not depend on gtk+ when building
rawhide SRPM nmap-2.54BETA22-2.src.rpm does not depend on gtk+ when building
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: nmap (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-22 13:54 EDT by Heikki Korpela
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-22 13:54:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Heikki Korpela 2001-07-22 13:54:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; OpenBSD 2.9 i386)

Description of problem:

nmap-2.54BETA22-2.src.rpm will try to build even when there is no gtk+
installed on the system but fail to create any packages because obviously
the frontend doesn't get built.

How reproducible:
Always

Steps to Reproduce:
1. Remove gtk+ if you have it on your system.
2. rpm --rebuild nmap-2.54BETA22-2.src.rpm
	

Actual Results:  error: File not found: /var/tmp/nmap-root/usr/bin/nmapfe
error: File not found: /var/tmp/nmap-root/usr/bin/xnmap
error: File not found: /var/tmp/nmap-root/usr/share/man/man1/nmapfe.1.gz
error: File not found: /var/tmp/nmap-root/usr/share/man/man1/xnmap.1.gz
Requires: nmap = 2.54BETA22 gtk+


RPM build errors:
    File not found: /var/tmp/nmap-root/usr/bin/nmapfe
    File not found: /var/tmp/nmap-root/usr/bin/xnmap
    File not found: /var/tmp/nmap-root/usr/share/man/man1/nmapfe.1.gz
    File not found: /var/tmp/nmap-root/usr/share/man/man1/xnmap.1.gz


Expected Results:  error: failed build dependencies:
        gtk+ is needed by nmap-2.54BETA22-2


Additional info:

The following patch should fix it:

--- nmap.spec.orig      Sun Jul 22 20:45:17 2001
+++ nmap.spec   Sun Jul 22 20:47:14 2001
@@ -23,6 +23,7 @@
 Summary: Gtk+ frontend for nmap
 Group: Applications/System
 Requires: nmap = %{PACKAGE_VERSION} , gtk+
+BuildRequires: gtk+
 %description frontend
 This package includes nmapfe, a Gtk+ frontend for nmap. The nmap package
must
 be installed before installing nmap-frontend.
@@ -64,6 +65,9 @@
 %{_mandir}/man1/xnmap.1.gz
 
 %changelog
+* Sun Jul 22 2001 Heikki Korpela <heko@iki.fi>
+- buildrequire gtk+ 
+
 * Tue Jul 10 2001 Tim Powers <timp@redhat.com>
 - fix bugs in desktop file (#48341)
Comment 1 Harald Hoyer 2001-07-23 05:54:09 EDT
thx

Note You need to log in before you can comment on or make changes to this bug.