Bug 496467 - Pulseaudio crashes after what appears to be an irq lockup
Pulseaudio crashes after what appears to be an irq lockup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-19 08:59 EDT by Jonathan Dieter
Modified: 2009-04-20 11:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-19 17:20:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Dieter 2009-04-19 08:59:02 EDT
Description of problem:
I am ripping a DVD iso (through an external DVD drive connected via USB) at the same time as I'm listening to music on MPD going through pulseaudio.

There's a glitch in reading the DVD, I get an odd error message from the (currently unused) bttv module saying "IRQ lockup, cleared int mask [bits: FMTCHG* VSYNC* HSYNC* OFLOW* HLOCK* VPRES* 6* 7* I2CDONE* GPINT* 10* RISCI* FBUS* FTRGT* FDSR* PPERR* RIPERR* PABORT* OCERR* SCERR*]"

Pulseaudio dies after logging an error message: "alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 738183072 bytes (3844703 ms) Most likely this is an ALSA driver bug. Please report this issue to the PulseAudio developers."

Version-Release number of selected component (if applicable):
pulseaudio-0.9.14-1.fc10.i386

How reproducible:
Mostly

Steps to Reproduce:
1. Rip a DVD from an external DVD drive
2. Wait until it hits a glitch in the DVD
  
Actual results:
Garbage through speakers as system temporarily locks, Pulseaudio dies

Expected results:
Garbage through speakers as system temporarily locks, pulseaudio keeps going
Comment 1 Lennart Poettering 2009-04-19 17:20:21 EDT
Please file a bug against the kernel regarding the irq lockup issue. PA has nothing to do with that.

The message you have shown suggests that PA has not been scheduled for one hour? Is that possible?

If not then this is a duplicate of either bug 485734 or bug 472339.

In any case, closing since this is not cause by PA itself.
Comment 2 Jonathan Dieter 2009-04-20 03:54:19 EDT
I'm sorry, maybe I wasn't clear.  I'm well aware that the irq lockup is a kernel bug, and, yes, PA was running right up until the alsa/driver bug was hit.  What I don't understand is why PA is dying.  I'm not familiar with the internals of alsa, but couldn't PA give the error message and then continue without exiting?
Comment 3 Lennart Poettering 2009-04-20 11:25:05 EDT
If snd_pcm_avail tells us to a ridiculous huge value we try to fulfil that. Which of course causes PA use a lot of CPU time. Then, the PA load limiter activates itself and kills PA. The reason for that is that if PA is run in RT mode we want to make that PA does not freeze the system. Not giving up the CPU for a longer time when RT sched is enabled translates to a freezing system.

Note You need to log in before you can comment on or make changes to this bug.