Bug 496529 - anaconda crash with swap file in fstab
anaconda crash with swap file in fstab
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:5d513c57762972398...
:
: 501332 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-19 20:00 EDT by Martin Ebourne
Modified: 2009-07-17 12:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-17 12:47:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (148.71 KB, text/plain)
2009-04-19 20:00 EDT, Martin Ebourne
no flags Details
fstab from affected system (859 bytes, text/plain)
2009-04-19 20:18 EDT, Martin Ebourne
no flags Details

  None (edit)
Description Martin Ebourne 2009-04-19 20:00:33 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.45 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/__init__.py", line 284, in setup
    raise FormatSetupError("invalid device specification")
  File "/usr/lib/anaconda/storage/formats/swap.py", line 118, in setup
    DeviceFormat.setup(self, *args, **kwargs)
  File "/usr/lib/anaconda/storage/__init__.py", line 1427, in turnOnSwap
    device.format.setup()
  File "/usr/lib/anaconda/upgrade.py", line 313, in upgradeMountFilesystems
    anaconda.id.storage.fsset.turnOnSwap(upgrading=True)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1323, in nextClicked
    self.anaconda.dispatch.gotoNext()
FormatSetupError: invalid device specification
Comment 1 Martin Ebourne 2009-04-19 20:00:42 EDT
Created attachment 340267 [details]
Attached traceback automatically from anaconda.
Comment 2 Martin Ebourne 2009-04-19 20:18:48 EDT
Created attachment 340268 [details]
fstab from affected system

fstab from affected system.

I've already had to edit the fstab to get this far, since I had some rbind lines in there that anaconda was also choking on.

I don't think it matters here but I'm doing something a bit unusual in that I'm upgrading a server machine remotely using the rawhide boot.iso. I've exported the server disk using nbd and created a kvm guest with the nbd as sda. The main reason I'm doing this is because anaconda just didn't grok the md raid setup I had (udevsettle kept hanging for no obvious reason at the filesystem searching stage).
Comment 3 David Lehman 2009-04-24 19:07:26 EDT
Both bind mounts and swap files should get mounted correctly as of anaconda-11.5.0.48-1, which was built today and should be in rawhide in a day or two.
Comment 4 James Laska 2009-05-22 08:44:10 EDT
Martin:  Are you able to verify that the reported issue has been resolved with the latest anaconda?  The process for downloading and installing rawhide directly is available at https://fedoraproject.org/wiki/Releases/Rawhide#Direct_Rawhide_install.
Comment 5 Martin Ebourne 2009-05-22 09:43:52 EDT
I've already upgraded this system by commenting the fstab entries out during the upgrade. In fact all my systems are now on F11 pre-release so I've got nothing left to upgrade.
Comment 6 Andy Lindeberg 2009-06-03 09:54:10 EDT
*** Bug 501332 has been marked as a duplicate of this bug. ***
Comment 7 Andy Lindeberg 2009-06-03 10:02:35 EDT
*** Bug 503830 has been marked as a duplicate of this bug. ***
Comment 8 Martí­n Marqués 2009-06-03 17:11:22 EDT
It's not working. See Bug 503830.
Comment 9 Bug Zapper 2009-06-09 10:09:15 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 David Lehman 2009-07-17 12:47:21 EDT
Ok -- one bug report per bug. If your swap file exists, then this is your bug. It has been resolved in anaconda-12.0-1.

If your bug involves an invalid swap line causing an anaconda crash, your bug is 503830. I have proposed a patch to resolve that issue and will update that bug accordingly when something changes.

Note You need to log in before you can comment on or make changes to this bug.