Bug 496548 - [FTBFS]: flex-2.5.35-3.fc11
[FTBFS]: flex-2.5.35-3.fc11
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: flex (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
https://www.redhat.com/archives/fedor...
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-19 22:32 EDT by Debarshi Ray
Modified: 2015-05-04 21:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-24 08:24:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated Spec. (9.96 KB, text/plain)
2009-04-19 22:33 EDT, Debarshi Ray
no flags Details
Patch to fix build failure. (829 bytes, patch)
2009-04-19 22:34 EDT, Debarshi Ray
no flags Details | Diff

  None (edit)
Description Debarshi Ray 2009-04-19 22:32:48 EDT
Description of problem:
Flex fails to build from source in Rawhide because one two of the checks in
its test-suite fails to build.

Version-Release number of selected component (if applicable):
flex-2.5.35-3.fc11

How reproducible:
Every time.

Steps to Reproduce:
1. $ fedora-cvs coredumper
2. $ cd coredumper/F-11
3. $ make scratch-build
  
Actual results:
Flex fails to build from source.

Expected results:
Flex should build successfully.

Additional info:
The generated C++ lexers refers to EOF, but Flex does not add a '#include <cstdio>', which it should. This causes a build failure with GCC 4.4.
Comment 1 Debarshi Ray 2009-04-19 22:33:42 EDT
Created attachment 340275 [details]
Updated Spec.
Comment 2 Debarshi Ray 2009-04-19 22:34:15 EDT
Created attachment 340276 [details]
Patch to fix build failure.
Comment 3 Petr Machata 2009-04-20 07:31:22 EDT
Thanks.  It's in the CVS and scratch build was tested.  I won't build it officially, since we are in devel freeze, unless I get explicit waiver.
Comment 4 Milos Jakubicek 2009-04-20 08:50:36 EDT
As there are no F11 build of flex at all, you should perform a normal build and request a freeze break, please follow https://fedoraproject.org/wiki/ReleaseEngineering/FinalFreezePolicy.
Comment 5 Petr Machata 2009-04-20 11:26:21 EDT
After reviewing goals of mass rebuild, I think it would be advantageous for flex to be rebuilt too.  Filed:
https://fedorahosted.org/rel-eng/ticket/1551
Comment 6 Bug Zapper 2009-06-09 10:10:21 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Petr Machata 2009-08-24 08:24:18 EDT
Already in repos.

Note You need to log in before you can comment on or make changes to this bug.