Bug 49657 - tdfx_dri.so incorrectly linked.
Summary: tdfx_dri.so incorrectly linked.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-22 20:04 UTC by Gerald Britton
Modified: 2007-04-18 16:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-23 21:53:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Britton 2001-07-22 20:04:26 UTC
Description of Problem:
tdfx_dri.so is apparnetly linked against the system installed
libXxf86dga.so.1 lib which is then not included in the package.


How Reproducible:
always

Steps to Reproduce:
1. RPM fails to install because of bad dependency.
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Valdis Kletnieks 2001-07-23 21:53:47 UTC
Broken in XFree86-4.1.0-0.8.6.  Looks like (according to rpm -q --changelog) at
least 3 attempts have been made since 4.1.0-0.7.2 to stamp out the Xv/xf86dga
libraries, with less than total sucess.

Comment 2 Mike A. Harris 2001-07-25 07:39:48 UTC
Often reported bug, a duplicate if you will. Don't have dupe #'s handy,
but this is fixed.  The problem was X picking up old libs in build system
despite the fact the specfile fixed the problem.  Solved by wiping X
out of buildsystem first, then building then installing X back.  Future
builds don't have the problem after the libXxf86dga.so* files are removed.



Note You need to log in before you can comment on or make changes to this bug.