Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 49659 - RFE: Changes to upgrade log file
RFE: Changes to upgrade log file
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-22 17:12 EDT by Stephen John Smoogen
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2001-07-22 17:12:41 EDT
It would be nice if /tmp/upgrade.log would list all the packages it
didnt upgrade as a seperate item. This would help the system
administratior see if he needs to remove items, clean out broken RPMS,
contact RH about it, or see if he needs to find an alternative vendor
for that package. The general format of the item would be:

Packages NOT upgraded:
-----------------------------
FreeBird-1.1.2-1
StairWayToHeaven-0.12-99
RockMeAmadeus-0.00-0
... yadda ...

It would be nice to have this also as a screen during a manual upgrade..
but that would be an 8.0 feature at least. This should be around a 20
line addition to anaconda (its about 4 lines of awk.. my python
sucks..)
Comment 1 Matt Wilson 2001-07-23 23:04:58 EDT
a) has been done for quite some time.  b) is "individual package selection".  It
may be possible to improve this in upgrage mode by filtering the new packages
from the ones already slected to be upgraded...
Comment 2 Stephen John Smoogen 2001-08-19 20:11:04 EDT
Matt,

I think you are misinterpreting what I am asking for.
What you have in the logs currently is:

Upgrading gal.
Upgrading ghostscript-fonts.
Upgrading glibc-common.
Upgrading gnome-audio-extra.
Upgrading mailcap.
......

The following packages were available in this version but NOT upgraded:
kdegraphics-devel-2.2-1.i386.rpm
tmake-1.7-3.noarch.rpm
XFree86-jpfonts-2.1-24.noarch.rpm
FreeWnn-libs-1.11-18.i386.rpm
..........


What this tells me is that the following RPMS were on the cdrom but were not
upgraded.. Or at least that is what I am hoping it is saying because I dont have
any of these RPMS installed on the system.

WHat I am looking for a simple report that could be mailed to root or something like

Thankyou for upgrading to 7.3.
The following packages on your system were upgraded:

Upgrading gal.
Upgrading ghostscript-fonts.
Upgrading glibc-common.
Upgrading gnome-audio-extra.
Upgrading mailcap.
.....

The following packages were NOT upgraded. They are not included with this
version of Red Hat Linux 7.3. They may have been installed as seperate packages,
or are no longer being maintained by Red Hat.

IBMJava2-JAAS-1.3-7.0
IBMJava2-JAVACOMM-1.3-7.0
IBMJava2-SDK-1.3-7.0
RealPlayer-7.0-7
StarOffice-5.2_01_569a19-2
acroread-4.05-6
autorun-2.65-1
basesystem-7.0-2
console-tools-19990829-34
control-panel-3.18-4
desktop-backgrounds-1.1-4
devfsd-2.4.3-12
docbook-dtd30-sgml-1.0-10
docbook-dtd31-sgml-1.0-10
docbook-dtd40-sgml-1.0-11
docbook-dtd41-sgml-1.0-10
epic-4_2000-6
ghostscript-fonts-5.50-3
gnome-audio-1.0.0-12
gnome-audio-extra-1.0.0-12
gnome-objc-1.0.2-11
gnome-objc-devel-1.0.2-11
htmlview-1.1.0-2
im-140-3
indexhtml-7.1-2
jbuilder_foundation-4-2
jphoto-0.3.6-1
libgal3-0.4.1-3
libgnomeprint11-0.25-9
microsoft-ttfonts-1.0-2
modemtool-1.22-3
mozilla-chat-2001081719-0_rh7
mozilla-mail-2001081719-0_rh7
mozilla-psm-2001081719-0_rh7
multimedia-2.1-21
perl-SGMLSpm-1.03ii-4
psgml-1.2.1-13
pythonlib-1.28-1
skey-0.2-3
telnet-0.17-18
tksysv-1.3-2
urw-fonts-2.0-12
xloadimage-4.1-20
xpaint-2.6.1-1
xv-3.10a-25
ymessenger-0.99.1-1

A detailed report would actually say which ones were Red Hat packages and what
ones werent.
Comment 3 Matt Wilson 2001-08-24 16:01:09 EDT
aaah, I understand.
Comment 4 Matt Wilson 2001-08-24 17:23:35 EDT
Pushing off for next release.
Comment 5 Michael Fulbright 2002-03-26 12:46:10 EST
Deferring to future release.
Comment 6 Red Hat Bugzilla 2006-02-21 13:48:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.