Bug 496605 - kernel config: disable CONFIG_CC_OPTIMIZE_FOR_SIZE on s390x
kernel config: disable CONFIG_CC_OPTIMIZE_FOR_SIZE on s390x
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-20 06:26 EDT by Jan Glauber
Modified: 2009-04-20 13:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 13:52:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Glauber 2009-04-20 06:26:14 EDT
CONFIG_CC_OPTIMIZE_FOR_SIZE should be disabled on s390/s390x.

Rationale: CONFIG_CC_OPTIMIZE_FOR_SIZE has a negative performance impact
on s390x. Network benchmarks show that this option costs ~ 3% performance
since the compiler generates non optimal code for instance for memcpy.
Comment 1 Dave Jones 2009-04-20 13:52:33 EDT
changed in cvs.

Note You need to log in before you can comment on or make changes to this bug.