Bug 496624 - [VirtualBox] snd_intel8x0 audio choppy
[VirtualBox] snd_intel8x0 audio choppy
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-20 08:22 EDT by Robin Green
Modified: 2009-08-04 08:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-04 08:16:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2009-04-20 08:22:19 EDT
Description of problem:
I previously uninstalled PulseAudio because of a different bug, so I'm using ALSA directly. Sound is continuously choppy and/or repetitive on recent rawhide kernels when running inside VirtualBox 2.2.0 OSE on Mac OS X (using the snd_intel8x0 driver).

Version-Release number of selected component (if applicable):
kernel-2.6.29.1-100.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. mplayer $FOO
  
Actual results:
Choppy audio

Expected results:
Good audio

Additional info:
2.6.29-0.159.rc6.git3.fc11.i586 works. I'll try and do some bisecting.
Comment 1 Robin Green 2009-04-20 08:53:41 EDT
My bisection reveals that this problem was introduced in this exact version: 2.6.29.1-70.fc11.i386. cc'ing wwoods since it was his patches.
Comment 2 Bug Zapper 2009-06-09 10:12:26 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Robin Green 2009-06-16 05:12:17 EDT
rmmod snd-intel8x0 and then modprobe snd-intel8x0 ac97_clock=41194 does not solve this issue (the parameter was suggested in another bug report).
Comment 4 Lubomir Rintel 2009-08-04 08:16:37 EDT
I am unable to reproduce this in Rawhide with in VirtualBox-OSE from RPM Fusion. 

Assuming the pcm positioning fix that went into 2.6.31 (see bug #506075) fixed that, closing. (please reopen if you manage to reproduce this).

Note You need to log in before you can comment on or make changes to this bug.