Bug 496630 - deleting all partitions from disk: Cannot remove non-leaf device 'vg_test1249'
deleting all partitions from disk: Cannot remove non-leaf device 'vg_test1249'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:d22ecdcf9d6deec1f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-20 09:04 EDT by James Laska
Modified: 2013-09-02 02:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 04:07:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (372.04 KB, text/plain)
2009-04-20 09:04 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (130.12 KB, text/plain)
2009-06-02 10:37 EDT, Darryl L. Pierce
no flags Details

  None (edit)
Description James Laska 2009-04-20 09:04:38 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.46 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 689, in _removeDevice
    raise ValueError("Cannot remove non-leaf device '%s'" % dev.name)
  File "/usr/lib/anaconda/storage/devicetree.py", line 735, in registerAction
    self._removeDevice(action.device)
  File "/usr/lib/anaconda/storage/__init__.py", line 645, in destroyDevice
    self.devicetree.registerAction(action)
  File "/usr/lib/anaconda/partIntfHelpers.py", line 165, in doDeleteDependentDevices
    storage.destroyDevice(dep)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 974, in deleteCB
    device):
ValueError: Cannot remove non-leaf device 'vg_test1249'
Comment 1 James Laska 2009-04-20 09:04:43 EDT
Created attachment 340341 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-04-20 09:18:29 EDT
Steps to reproduce:

1) Initiate a kvm x86_64 install of Fedora with 4 virtio attached disks
2) Add an iSCSI volume using ip:192.168.33.219, iqn: iqn.rhel5.x8664
3) Check [X] Review partitions 
4) The '/boot' volume is placed on the iSCSI drive (sda), which was not intended.  I clicked on the iSCSI drive 'sda' and selected "Delete" to remove all partitions on the drive.
Comment 3 Hans de Goede 2009-04-24 04:07:41 EDT
James,

I've managed to reproduce this using my own iscsi setup, and this is fixed now
by this commit:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=cbccdd0dc1c3aa1aa3aac47cd47aebb986840d29

I've verified the fix, so closing.
Comment 4 Darryl L. Pierce 2009-06-02 10:37:19 EDT
Created attachment 346262 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.