Bug 496649 - glxgears radeon 9000 assertion in cs_gem_write_reloc
glxgears radeon 9000 assertion in cs_gem_write_reloc
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-04-20 10:26 EDT by Nikolay Vladimirov
Modified: 2010-05-18 11:16 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-05-18 11:16:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg (36.77 KB, text/plain)
2009-04-20 10:26 EDT, Nikolay Vladimirov
no flags Details
Xorg log (50.39 KB, text/plain)
2009-04-20 10:27 EDT, Nikolay Vladimirov
no flags Details
dmesg output (26.24 KB, text/plain)
2009-05-11 19:55 EDT, Sam
no flags Details
Xorg.0.log (118.37 KB, text/plain)
2009-05-11 19:56 EDT, Sam
no flags Details
dmesg after 7.5-0.14 update (26.52 KB, text/plain)
2009-05-14 21:10 EDT, Sam
no flags Details
Xorg.0.log after 7.5-0.14 update (118.37 KB, text/plain)
2009-05-14 21:11 EDT, Sam
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 21374 None None None Never

  None (edit)
Description Nikolay Vladimirov 2009-04-20 10:26:12 EDT
Created attachment 340351 [details]

Description of problem:
Using clean fedora 11 latest rawhide network install. No manual modification. just opened up a terminal and ran glxgears.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.run glxgears
Actual results:
glxgears exits with:
glxgears: radeon_cs_gem.c:121: cs_gem_write_reloc: Assertion `bo->space_accounted` failed.

Expected results:
Normal glxgears run.

Additional info:
there are some radeon related messages from the kernel. Attaching dmesg and Xorg.0.log
Comment 1 Nikolay Vladimirov 2009-04-20 10:27:27 EDT
Created attachment 340352 [details]
Xorg log
Comment 2 Ezra Peisach 2009-04-23 20:43:39 EDT
This problem also happens on a Radeon M9 (rv250) (r200 driver)... Same error...
Comment 3 Nikolay Vladimirov 2009-04-24 05:37:14 EDT
Just some hardware clarification it's not actually Radeon 9000 but:
ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] rev 2
(as seen in Xorg log)

Also this is on Thinkpad T41 if it makes any difference.
Comment 4 Ezra Peisach 2009-04-24 20:32:02 EDT
I just tried compiling the radeon_rewrite branch of the mesa development tree (4/24/09) (which is where the ati driver package is getting its code).

glxgears now works (other apps have issues - but I will wait until these fixes are incorporated before reporting them against a third party source tree)

So - I guess we need a pullup...

(oh yeah - my card is on an inspiron 8200)
Comment 5 Tim Wegener 2009-05-01 12:34:24 EDT
I also get this error with the following video card:
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV280 [Radeon 9200 PRO] [1002:5960] (rev 01)

When I use the "nomodeset" kernel option and try to run glxgears the screen goes blank and I have to do a hard reset (reset button). Similarly for etracer: 

%%% etracer warning: Attempt to bind to Texture unloaded texture: `b-herring_run_icon'

etracer: radeon_cs_gem.c:121: cs_gem_write_reloc: Assertion `bo->space_accounted' failed.
Comment 6 Sam 2009-05-11 19:53:24 EDT
I'm having the same problem on a fully updated F11 Preview installation. When I run glxgears, I see a small, completely black window pop up for a fraction of a second before disappearing, and I see this on the terminal:
[sam@localhost log]$ glxgears
glxgears: radeon_cs_gem.c:121: cs_gem_write_reloc: Assertion `bo->space_accounted' failed.
[sam@localhost log]$

If I boot with nomodeset, glxgears runs fine, though it prints "Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate." when it starts. Could be significant, but I have no idea.

Rpm versions:

My card is a Radeon 9000. I'll attach dmesg and Xorg.0.log; there's no Xorg.conf.
Comment 7 Sam 2009-05-11 19:55:29 EDT
Created attachment 343517 [details]
dmesg output
Comment 8 Sam 2009-05-11 19:56:14 EDT
Created attachment 343518 [details]
Comment 9 Sam 2009-05-14 21:09:04 EDT
This is somewhat fixed for me with glx-utils-7.5-0.14.fc11.i586. glxgears runs with modesetting enabled, but at one tenth the framerate of nomodeset. It also keeps spewing out the following error about as fast as it can:

CS section size missmatch start at (r200_state_init.c,ctx_emit_cs,510) 22 vs 26
CS section end at (r200_state_init.c,ctx_emit_cs,543)

This happens both on kernel- and kernel-, still with xorg-x11-drv-ati-6.12.2-13.fc11.i586.

Is this a continuation of this bug, or should I file a new bug report? I'll go ahead and attach dmesg and Xorg.0.log in case it fits here.
Comment 10 Sam 2009-05-14 21:10:50 EDT
Created attachment 344066 [details]
dmesg after 7.5-0.14 update
Comment 11 Sam 2009-05-14 21:11:48 EDT
Created attachment 344067 [details]
Xorg.0.log after 7.5-0.14 update
Comment 12 Adam Pribyl 2009-05-22 07:32:32 EDT
Here is ATI Technologies Inc RV280 [Radeon 9200], running glx gears as of todays updates results in 
CS section size missmatch start at (r200_state_init.c,ctx_emit_cs,510) 22 vs 26
CS section end at (r200_state_init.c,ctx_emit_cs,543)

With Xorg.0.log
EXA bug: Trying to call driver FinishAccess hook with unsupported index EXA_PREPARE_AUX*

glxgears are drawn but somehow choppy. 

In messages I have every than and now variations of:

i2c-adapter i2c-0: unable to read EDID block.
radeon 0000:01:00.0: VGA-1: no EDID data
[drm:edid_is_valid] *ERROR* Raw EDID:
<3>00 00 00 00 00 00 00 00 00 00 00 00 00 7f ff ff  ................
<3>ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff  ................
<3>ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff  ................
<3>ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff  ................
<3>ff ff ff ff ff ff ff ff ff ff f8 00 00 00 00 00  ................
<3>00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  ................
<3>00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  ................
<3>00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  ................

radeon 0000:01:00.0: VGA-1: EDID invalid.
Comment 13 Bug Zapper 2009-06-09 10:12:57 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
Comment 14 Jan Sedlák 2009-09-25 14:12:49 EDT
Same on my laptop. I have clean F11 with KDE, and laptop IBM T42 (with ATI Mobiliti Radeon 7500) and when I want to run Glest (on old F10 it was without problem) it shows the game logo and when it wants to show game menu, it fail with 

glest: radeon_cs_gem.c:121: cs_gem_write_reloc: Assertion `bo->space_accounted' failed.
Neúspěšně ukončen (SIGABRT)

Please, fix it! I want to play my Glest :-)
Comment 15 Matěj Cepl 2009-11-05 13:27:10 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 16 Nikolay Vladimirov 2009-11-05 14:35:07 EST
I no longer have the machine( Thinkapd T41). I can't reproduce this. There were several folks who commented here, maybe one of them can try to reproduce it.
Comment 17 Tim Wegener 2009-11-06 23:51:03 EST
This works fine for me now, without enabling updates-testing.


(with kernel mode setting enabled)
Comment 18 Jan Sedlák 2009-11-07 03:08:39 EST
Still not working on my Think Pad T42, but I'll try to enablerepo testing or move to F12 in 10 days.
Comment 19 Jan Sedlák 2009-11-17 16:29:28 EST
So, I've just preupgraded to new F12 and when I'm trying to play Glest, it fails and in the konsole is:

File radeon_tcl.c function radeon_run_tcl_render line 499
Rendering was 762 commands larger than predicted size. We might overflow  command buffer.
drmRadeonCmdBuffer: -22. Kernel failed to parse or rejected command stream. See dmesg for more info.
Comment 20 Ezra Peisach 2009-11-19 12:31:23 EST
With F12 - on my machine - (inspiron 8200 w/ Radeon 9600 card) - w/o the nomodeset, glxgears colors are all wrong.  I do not get the assertion with glxgears - but do get an assertion with pymol. (just start the program).
Comment 21 Roberto Vergara B. 2010-02-22 22:51:08 EST
In my box, F12 Intel, Radeon 9200SE, glxgears runs fine but gnubik is very slow and celestia just don't run

drmRadeonCmdBuffer: -22. Kernel failed to parse or rejected command stream. See dmesg for more info.

 dmesg says:
[drm:edid_is_valid] *ERROR* EDID checksum is invalid, remainder is 49
Comment 22 Bug Zapper 2010-04-27 09:48:46 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 23 Adam Pribyl 2010-05-18 11:16:49 EDT
Last reports are probably related to https://bugzilla.redhat.com/show_bug.cgi?id=533632 but the gem assertion message is not present anymore (F13). Closing.

Note You need to log in before you can comment on or make changes to this bug.