Bug 496679 - Use instance-specific paths rather than redirected paths in Execution Management Scripts
Use instance-specific paths rather than redirected paths in Execution Managem...
Status: CLOSED ERRATA
Product: Dogtag Certificate System
Classification: Community
Component: Execution Management (start/stop/restart) (Show other bugs)
1.1
All Linux
high Severity medium
: ---
: ---
Assigned To: Matthew Harmsen
Chandrasekar Kannan
:
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2009-04-20 12:58 EDT by Matthew Harmsen
Modified: 2015-01-04 18:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 19:34:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Revised execution scripts (11.36 KB, patch)
2009-04-20 17:38 EDT, Matthew Harmsen
no flags Details | Diff
Revised execution scripts (spec files) (5.78 KB, patch)
2009-04-20 17:38 EDT, Matthew Harmsen
no flags Details | Diff

  None (edit)
Description Matthew Harmsen 2009-04-20 12:58:00 EDT
It was discovered that the Execution Management scripts used redirected paths
(e. g. - /etc) rather than the instance-specific paths
(e. g. - /var/lib/<instance>/conf).

Since redirected paths are optional, this led to problems such as the following:

% /sbin/service pki-ca status
pki-ca (pid 10756) is running ...
grep: /etc/pki-ca/CS.cfg: No such file or directory

    Unsecure Port     = http://pkilinux.sjc.redhat.com:9180/ca/ee/ca
    Secure Agent Port = https://pkilinux.sjc.redhat.com:9443/ca/agent/ca
    Secure EE Port    = https://pkilinux.sjc.redhat.com:9444/ca/ee/ca
    Secure Admin Port = https://pkilinux.sjc.redhat.com:9445/ca/services
    Secure Admin Port = pkiconsole https://pkilinux.sjc.redhat.com:9445/ca
    Tomcat Port       = 9701 (for shutdown)
Comment 1 Matthew Harmsen 2009-04-20 17:38:16 EDT
Created attachment 340437 [details]
Revised execution scripts
Comment 2 Matthew Harmsen 2009-04-20 17:38:45 EDT
Created attachment 340438 [details]
Revised execution scripts (spec files)
Comment 3 Andrew Wnuk 2009-04-20 17:52:27 EDT
attachment (id=340437)
attachment (id=340438)
+awnuk
fix does not include DonePanel
Comment 4 Matthew Harmsen 2009-04-20 17:58:42 EDT
cd pki/base

% svn status | grep -v ^$ | grep -v ^P | grep -v ^X | grep -v ^?
M      ca/shared/etc/init.d/httpd
M      tks/shared/etc/init.d/httpd
M      ra/etc/init.d/httpd
M      ocsp/shared/etc/init.d/httpd
M      tps/etc/init.d/httpd
M      kra/shared/etc/init.d/httpd

% svn commit
Sending        base/ca/shared/etc/init.d/httpd
Sending        base/kra/shared/etc/init.d/httpd
Sending        base/ocsp/shared/etc/init.d/httpd
Sending        base/ra/etc/init.d/httpd
Sending        base/tks/shared/etc/init.d/httpd
Sending        base/tps/etc/init.d/httpd
Transmitting file data ......
Committed revision 404.


cd pki/dogtag

% svn status | grep -v ^$ | grep -v ^P | grep -v ^X | grep -v ^?
M      ca/pki-ca.spec
M      tks/pki-tks.spec
M      ra/pki-ra.spec
M      ocsp/pki-ocsp.spec
M      tps/pki-tps.spec
M      kra/pki-kra.spec

% svn commit
Sending        dogtag/ca/pki-ca.spec
Sending        dogtag/kra/pki-kra.spec
Sending        dogtag/ocsp/pki-ocsp.spec
Sending        dogtag/ra/pki-ra.spec
Sending        dogtag/tks/pki-tks.spec
Sending        dogtag/tps/pki-tps.spec
Transmitting file data ......
Committed revision 405.

Note You need to log in before you can comment on or make changes to this bug.