Bug 49673 - KDevelop crashes when I create a new project.
KDevelop crashes when I create a new project.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kdevelop (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-22 21:13 EDT by Scott Duns
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-26 21:13:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Duns 2001-07-22 21:13:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2-TestCompile i686)

Description of problem:
When I create a new project in KDevelop, it always crashes when I answer
all questions and click create.  Crash:
#0  0x41026519 in __wait4 () from /lib/i686/libc.so.6
#1  0x410969e4 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40859998 in KCrash::defaultCrashHandler () at eval.c:41
#3  <signal handler called>
#4  0x080fdb3c in KDialog::marginHint () at eval.c:41
#5  0x084a505c in ?? () at eval.c:41
#6  0x080c6f2b in KDialog::marginHint () at eval.c:41
#7  0x40813282 in KProcess::processExited () at eval.c:41
#8  0x408991f1 in KProcess::processHasExited () at eval.c:41
#9  0x40813abf in KProcessController::slotDoHousekeeping () at eval.c:41
#10 0x40b04011 in QObject::activate_signal ()
   from /usr/lib/qt-2.3.0/lib/libqt.so.2
#11 0x40b5b8b6 in QSocketNotifier::activated ()
   from /usr/lib/qt-2.3.0/lib/libqt.so.2
#12 0x40b392d7 in QSocketNotifier::event ()
   from /usr/lib/qt-2.3.0/lib/libqt.so.2
#13 0x40aac154 in QApplication::notify () from
/usr/lib/qt-2.3.0/lib/libqt.so.2
#14 0x40800019 in KApplication::notify () at eval.c:41
#15 0x40a7734b in sn_activate () from /usr/lib/qt-2.3.0/lib/libqt.so.2
#16 0x40a77bbf in QApplication::processNextEvent ()
   from /usr/lib/qt-2.3.0/lib/libqt.so.2
#17 0x40aadfec in QApplication::enter_loop ()
   from /usr/lib/qt-2.3.0/lib/libqt.so.2
#18 0x40ab3534 in QDialog::show () from /usr/lib/qt-2.3.0/lib/libqt.so.2
#19 0x40c869e3 in QWizard::show () from /usr/lib/qt-2.3.0/lib/libqt.so.2
#20 0x40ab2eaf in QDialog::exec () from /usr/lib/qt-2.3.0/lib/libqt.so.2
#21 0x0813c50a in KDialog::marginHint () at eval.c:41
#22 0x40b04011 in QObject::activate_signal ()
   from /usr/lib/qt-2.3.0/lib/libqt.so.2
#23 0x40b36f42 in QSignal::activate () from
/usr/lib/qt-2.3.0/lib/libqt.so.2
#24 0x40bd8479 in QPopupMenu::mouseReleaseEvent ()
   from /usr/lib/qt-2.3.0/lib/libqt.so.2
#25 0x40b4dd11 in QWidget::event () from /usr/lib/qt-2.3.0/lib/libqt.so.2
#26 0x40aac154 in QApplication::notify () from
/usr/lib/qt-2.3.0/lib/libqt.so.2
#27 0x40800019 in KApplication::notify () at eval.c:41
#28 0x40a7ae14 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-2.3.0/lib/libqt.so.2
#29 0x40a78488 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-2.3.0/lib/libqt.so.2
#30 0x40a7743a in QApplication::processNextEvent ()
   from /usr/lib/qt-2.3.0/lib/libqt.so.2
#31 0x40aadfec in QApplication::enter_loop ()
   from /usr/lib/qt-2.3.0/lib/libqt.so.2
#32 0x40a773b7 in QApplication::exec () from
/usr/lib/qt-2.3.0/lib/libqt.so.2
#33 0x080dcc6e in KDialog::marginHint () at eval.c:41
#34 0x40f88177 in __libc_start_main (
    main=0x80dc8d0 <KDialog::marginHint(void)+480112>, argc=8,
    ubp_av=0xbffffb3c, init=0x8061438 <_init>, fini=0x826a230 <_fini>,
    rtld_fini=0x4000e184 <_dl_fini>, stack_end=0xbffffb2c)
    at ../sysdeps/generic/libc-start.c:129

How reproducible:
Always

Steps to Reproduce:
1. Open KDevelop
2. Create a new project for C++ terminal	
3. Answer all questions default and when Next shadows, click Create
	

Actual Results:  Always crashes with crash data I included above.	

Expected Results:  It should have created a new project.

Additional info:

None
Comment 1 Ngo Than 2001-07-24 05:00:30 EDT
i cannot reproduce it on my machine and laptop. It works for me.
are you sure that, you only have installed RedhatKDE RPM packages from 7.1?
Comment 2 Scott Duns 2001-07-26 21:13:37 EDT
I have installed a few RPMs form the RedHat CDs after I initially installed
RedHat 7.1, but that should not cause a problem such as this.  I noticed a few
pieces such as the gnome pieces report not available when I run the KDevelop
setup.
Comment 3 Ngo Than 2001-08-02 06:34:26 EDT
i cannot reproduce it definitive even on a fresh installed Redhat 7.1 machine.
please sende me the output 'rpm -qa | grep "^kde" and "rpm -qi kdevelop"

Note You need to log in before you can comment on or make changes to this bug.