Bug 496738 - Pidgin Crashes Prior To Connecting To AIM Protocol
Pidgin Crashes Prior To Connecting To AIM Protocol
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-20 17:16 EDT by Bob Cochran
Modified: 2009-06-13 21:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-13 21:19:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Cochran 2009-04-20 17:16:12 EDT
Description of problem:

When starting pidgin in Fedora 11, the GUI freezes up before I can complete entering my password for the AIM signon process. 

Version-Release number of selected component (if applicable):

pidgin-2.5.5-1.fc11.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Start pidgin by either clicking Applications --> Internet --> Internet Messenger or opening a terminal and running pidgin.
2. Attempt to connect to the AIM protocol by typing in the password for the desired screen name.
3. Observe that the gui window for the password locks up and does not allow one to complete typing in the password.
  
Actual results:

Cannot type in the password associated with a screen name in the pidgin password prompt window.

Expected results:

Ability to complete typing in the password at this prompt, and then successfully connecting to the AIM service.

Additional info:

I obtained this from running pidgin -d:

[rlc@deafeng3 ~]$ pidgin -d
(16:49:02) prefs: Reading /home/rlc/.purple/prefs.xml
(16:49:02) prefs: Finished reading /home/rlc/.purple/prefs.xml
(16:49:02) dbus: okkk
(16:49:02) plugins: probing /usr/lib64/pidgin/markerline.so
(16:49:02) plugins: probing /usr/lib64/pidgin/gtkbuddynote.so
(16:49:02) plugins: probing /usr/lib64/pidgin/nautilus.so
(16:49:02) plugins: probing /usr/lib64/pidgin/ticker.so
(16:49:02) plugins: probing /usr/lib64/pidgin/gevolution.so
(16:49:02) plugins: probing /usr/lib64/pidgin/history.so
(16:49:02) plugins: probing /usr/lib64/pidgin/spellchk.so
(16:49:02) plugins: probing /usr/lib64/pidgin/iconaway.so
(16:49:02) plugins: probing /usr/lib64/pidgin/notify.so
(16:49:02) plugins: probing /usr/lib64/pidgin/gestures.so
(16:49:02) plugins: probing /usr/lib64/pidgin/xmppconsole.so
(16:49:02) plugins: probing /usr/lib64/pidgin/pidginrc.so
(16:49:02) plugins: probing /usr/lib64/pidgin/timestamp_format.so
(16:49:02) plugins: probing /usr/lib64/pidgin/sendbutton.so
(16:49:02) plugins: probing /usr/lib64/pidgin/musicmessaging.so
(16:49:02) plugins: probing /usr/lib64/pidgin/convcolors.so
(16:49:02) plugins: probing /usr/lib64/pidgin/extplacement.so
(16:49:02) plugins: probing /usr/lib64/pidgin/timestamp.so
(16:49:02) plugins: probing /usr/lib64/purple-2/autoaccept.so
(16:49:02) plugins: probing /usr/lib64/purple-2/libsilcpurple.so
(16:49:02) plugins: probing /usr/lib64/purple-2/libmsn.so
(16:49:02) plugins: probing /usr/lib64/purple-2/libyahoo.so
(16:49:02) plugins: probing /usr/lib64/purple-2/libicq.so
(16:49:02) plugins: probing /usr/lib64/purple-2/libsametime.so
(16:49:02) plugins: /usr/lib64/purple-2/libsametime.so has a prefs_info, but is a prpl. This is no longer supported.
(16:49:02) plugins: probing /usr/lib64/purple-2/libnovell.so
(16:49:02) plugins: probing /usr/lib64/purple-2/idle.so
(16:49:02) plugins: probing /usr/lib64/purple-2/libsimple.so
(16:49:02) plugins: probing /usr/lib64/purple-2/joinpart.so
(16:49:02) plugins: probing /usr/lib64/purple-2/libirc.so
(16:49:02) plugins: probing /usr/lib64/purple-2/libmyspace.so
(16:49:02) plugins: probing /usr/lib64/purple-2/psychic.so
(16:49:02) plugins: probing /usr/lib64/purple-2/newline.so
(16:49:02) plugins: probing /usr/lib64/purple-2/ssl.so
(16:49:02) plugins: probing /usr/lib64/purple-2/statenotify.so
(16:49:02) plugins: probing /usr/lib64/purple-2/libgg.so
(16:49:02) plugins: probing /usr/lib64/purple-2/buddynote.so
(16:49:02) plugins: probing /usr/lib64/purple-2/libjabber.so
(16:49:02) plugins: /usr/lib64/purple-2/libjabber.so is not usable because the 'purple_init_plugin' symbol could not be found.  Does the plugin call the PURPLE_INIT_PLUGIN() macro?
(16:49:02) plugins: probing /usr/lib64/purple-2/one_time_password.so
(16:49:02) plugins: probing /usr/lib64/purple-2/offlinemsg.so
(16:49:02) plugins: probing /usr/lib64/purple-2/libxmpp.so
(16:49:02) util: Reading file xmpp-caps.xml from directory /home/rlc/.purple
(16:49:02) util: File /home/rlc/.purple/xmpp-caps.xml does not exist (this is not necessarily an error)
(16:49:02) jabber: creating hash tables for data objects
(16:49:02) plugins: probing /usr/lib64/purple-2/libqq.so
(16:49:02) plugins: probing /usr/lib64/purple-2/ssl-nss.so
(16:49:02) plugins: probing /usr/lib64/purple-2/libaim.so
(16:49:02) plugins: probing /usr/lib64/purple-2/libbonjour.so
(16:49:02) plugins: probing /usr/lib64/purple-2/liboscar.so
(16:49:02) plugins: /usr/lib64/purple-2/liboscar.so is not usable because the 'purple_init_plugin' symbol could not be found.  Does the plugin call the PURPLE_INIT_PLUGIN() macro?
(16:49:02) plugins: probing /usr/lib64/purple-2/libzephyr.so
(16:49:02) plugins: probing /usr/lib64/purple-2/dbus-example.so
(16:49:02) plugins: probing /usr/lib64/purple-2/log_reader.so
(16:49:02) prefs: /purple/status/scores/offline changed, scheduling save.
(16:49:02) prefs: /purple/status/scores/available changed, scheduling save.
(16:49:02) prefs: /purple/status/scores/invisible changed, scheduling save.
(16:49:02) prefs: /purple/status/scores/away changed, scheduling save.
(16:49:02) prefs: /purple/status/scores/extended_away changed, scheduling save.
(16:49:02) prefs: /purple/status/scores/idle changed, scheduling save.
(16:49:02) prefs: /purple/status/scores/offline_msg changed, scheduling save.
(16:49:02) util: Reading file accounts.xml from directory /home/rlc/.purple
(16:49:02) util: Reading file status.xml from directory /home/rlc/.purple
(16:49:02) certificate: CertificateVerifier x509, singleuse requested but not found.
(16:49:02) certificate: CertificateVerifier singleuse registered
(16:49:02) certificate: CertificatePool x509, ca requested but not found.
(16:49:02) certificate: CertificateScheme x509 requested but not found.
(16:49:02) certificate/x509/ca: Lazy init failed because an X.509 Scheme is not yet registered. Maybe it will be better later.
(16:49:02) certificate/x509/ca: Init failed, probably because a dependency is not yet registered. It has been deferred to later.
(16:49:02) certificate: CertificatePool ca registered
(16:49:02) certificate: CertificatePool x509, tls_peers requested but not found.
(16:49:02) certificate: CertificatePool tls_peers registered
(16:49:02) certificate: CertificateVerifier x509, tls_cached requested but not found.
(16:49:02) certificate: CertificateVerifier tls_cached registered
(16:49:02) prefs: /purple/logging/format changed, scheduling save.
(16:49:02) prefs: /purple/logging/format changed, scheduling save.
(16:49:02) prefs: /purple/proxy/type changed, scheduling save.
(16:49:02) prefs: /purple/proxy/host changed, scheduling save.
(16:49:02) prefs: /purple/proxy/port changed, scheduling save.
(16:49:02) prefs: /purple/proxy/username changed, scheduling save.
(16:49:02) prefs: /purple/proxy/password changed, scheduling save.
(16:49:02) certificate: CertificateScheme x509 requested but not found.
(16:49:02) certificate: CertificateScheme x509 registered
(16:49:02) util: Reading file smileys.xml from directory /home/rlc/.purple
(16:49:02) util: File /home/rlc/.purple/smileys.xml does not exist (this is not necessarily an error)
(16:49:02) stun: using server 
(16:49:02) sound: Initializing sound output drivers.
(16:49:02) prefs: /pidgin/conversations/placement changed, scheduling save.
(16:49:02) gtkblist: added visibility manager: 1
(16:49:02) docklet: created
(16:49:02) util: Reading file blist.xml from directory /home/rlc/.purple
(16:49:02) plugins: Loading saved plugin /usr/lib64/pidgin/extplacement.so
(16:49:02) prefs: /pidgin/conversations/placement changed, scheduling save.
(16:49:02) plugins: Loading saved plugin /usr/lib64/pidgin/history.so
(16:49:02) plugins: Loading saved plugin /usr/lib64/pidgin/notify.so
(16:49:02) plugins: Loading saved plugin /usr/lib64/purple-2/ssl-nss.so
(16:49:02) plugins: Loading saved plugin /usr/lib64/pidgin/nautilus.so
(16:49:02) nautilus: saved blist online
(16:49:02) plugins: Loading saved plugin /usr/lib64/purple-2/ssl.so
(16:49:02) pounce: Error reading pounces: Failed to open file '/home/rlc/.purple/pounces.xml': No such file or directory
(16:49:02) ui_main: Failed to load the default window icon (scalablepx version)!
(16:49:02) Session Management: ICE initialized.
(16:49:02) Session Management: Connecting with no previous ID
(16:49:02) Session Management: Handling new ICE connection... 
(16:49:02) done.
(16:49:02) Session Management: Connected to manager (gnome-session) with client ID 10206f070c220c4002124026054286850800000024520034
(16:49:02) Session Management: Using pidgin as command
(16:49:02) dbus: Need to register an object with the dbus subsystem. (If you are not a developer, please ignore this message.)
(16:49:02) dbus: The signal "gtkblist-hiding" caused some dbus error. (If you are not a developer, please ignore this message.)
(16:49:02) account: Connecting to account BobCochran
(16:49:02) Session Management: Received first save_yourself
(16:49:02) Session Management: Received save_complete
(16:49:02) docklet: embedded
Killed
Comment 1 Bug Zapper 2009-06-09 10:15:03 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Craig Connors 2009-06-13 20:36:22 EDT
Seems to be already fixed in pidgin-2.5.6-1.fc11.x86_64

Note You need to log in before you can comment on or make changes to this bug.