Bug 496759 - esc: User enrollment throws coolkey PKCS #11 CSP error
esc: User enrollment throws coolkey PKCS #11 CSP error
Status: CLOSED ERRATA
Product: Dogtag Certificate System
Classification: Community
Component: ESC (Show other bugs)
unspecified
All Linux
high Severity high
: ---
: ---
Assigned To: Jack Magne
Chandrasekar Kannan
:
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2009-04-20 20:17 EDT by Asha Akkiangady
Modified: 2015-01-04 18:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 19:34:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
At the end of the user enrollment shows 2 'Please enter your PIN' dialog boxes. (132.34 KB, image/pjpeg)
2009-04-20 20:17 EDT, Asha Akkiangady
no flags Details
Error during PIN verification message, when correct pin is entered. (141.96 KB, image/pjpeg)
2009-04-20 20:19 EDT, Asha Akkiangady
no flags Details

  None (edit)
Description Asha Akkiangady 2009-04-20 20:17:21 EDT
Created attachment 340457 [details]
At the end of the user enrollment shows 2  'Please enter your PIN' dialog boxes.

Description of problem:
User enrollment made with no changes to default esc-prefs.js shows 2 dialog boxes to enter the pin. Entering the correct pin leads to PKCS #11 CSP error.

Version-Release number of selected component (if applicable):
CS 8.0

How reproducible:


Steps to Reproduce:
Test is run on windows XP.
1. With the default esc-prefs.js setting start the esc application.
2. Insert token to the usb drive and enroll a user.

Actual results:
Has 2 'Please enter your PIN' dialog boxes. If you enter the correct pin them, throws PKCS #11 CSP error.

Expected results:
Should not show 2 'Please enter your PIN' dialog boxes. Entering correct PIN should not throw error.

Additional info:
Comment 1 Asha Akkiangady 2009-04-20 20:19:34 EDT
Created attachment 340458 [details]
Error during PIN verification message, when correct pin is entered.
Comment 2 Jack Magne 2009-06-05 20:17:57 EDT
This is caused by a bogus token removal event that takes place at the end of an enrollment. The bogus removal event is then followed by a bogus insertion event.
Comment 3 Jack Magne 2009-06-05 20:18:26 EDT
The following change fixes this:

Index: SmartCardMonitoringThread.cpp
===================================================================
RCS file: /cvs/dirsec/esc/src/lib/coolkey/SmartCardMonitoringThread.cpp,v
retrieving revision 1.4
diff -r1.4 SmartCardMonitoringThread.cpp
162c162
<         if (info && (!isPresent || (info->mSeries != PK11_GetSlotSeries(slot))
) ) {
---
>         if (info && !isPresent) {
Comment 4 Matthew Harmsen 2009-06-05 20:21:17 EDT
Comment #3 +mharmsen
Comment 5 Jack Magne 2009-06-05 20:24:05 EDT
Checking in SmartCardMonitoringThread.cpp;
/cvs/dirsec/esc/src/lib/coolkey/SmartCardMonitoringThread.cpp,v  <--  SmartCardM
onitoringThread.cpp
new revision: 1.5; previous revision: 1.4
done
Running syncmail...
Mailing relnotes@fedoraproject.org...
...syncmail done.
Running syncmail...
Mailing cvsdirsec@fedoraproject.org...
...syncmail done.
Comment 6 Jack Magne 2009-06-05 20:24:27 EDT
Will be fixed in next build.
Comment 7 Asha Akkiangady 2009-06-10 19:01:51 EDT
Verified.

Performed user enrollment with ESC build SmartCardManagerSetup-1.1.0-6.win32.i386.exe, no issues with pin verification.

Note You need to log in before you can comment on or make changes to this bug.