Bug 49676 - Installer cannot partition hard drive properly - corrupting partition tables
Installer cannot partition hard drive properly - corrupting partition tables
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-22 21:19 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-23 22:56:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from error from attempt to use partitionless method (10.70 KB, text/plain)
2001-07-22 21:20 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-07-22 21:19:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Win95; U)

Description of problem:
Having problems installing RH7.1 as a dual boot system with WinXP RC1 (uses NTFS). Trying to format like this on a 6 Gig Quantum HD:

hda1 - NTFS - 3 Gigs for WinXP
hda2 - /boot - 16 Megs
hda5 - SWAP - 512 Megs
hda6 - / - about 2.5 Gigs

I've generally tried doing this after WinXP is installed.

Have tried using Disk Druid manually, tried using expert mode to install Lilo info to the /boot partition, even tried using fdisk. Genrally, have 
gotten through setup and at the point where it starts to format and install packages and received the following error:

"An error occurred trying to format /. This problem is serious and the install cannot continue. Press Enter to reboot the system."

After rebooting I find that the partition table is gone so I can't get WinXP back either.

Also tried installing RH7.1 into a FAT partition (using the partionless method), but got an error just after selecting the FAT partition for the / 
partition. I was given the option to save a dump to a file and will add that as an attachment to this bug report when I get the email for this bug 
report.

To add insult to injury, RH7.1 cannot seem to completely overwrite a HD that has had WinXP or late version of Win9x (including WinME) 
installed on it. I've had trouble installing RH7.1 on another drive but didn't test that other drive much. (It's now in use for a Win partition.)

Oddly, Red Hat 7.0 and Red Hat 6.0 install just fine (without expert mode but manually adding partitions through Disk Druid) with WinXP 
already installed.

System specs:

Aopen AX3SPro MB (Intel 815 chipset)
PIII800 CPU
512 MG RAM
6 GB Quantum HD

How reproducible:
Always

Steps to Reproduce:
1.Try to install RH7.1 on HD (either with WinXP installed or trying to overwrite the entire drive)
2.
3.
	

Actual Results:  Lost partition tables. Errors.

Expected Results:  Dual boot system.

Additional info:
Comment 1 Need Real Name 2001-07-22 21:20:31 EDT
Created attachment 24549 [details]
Output from error from attempt to use partitionless method
Comment 2 Brent Fox 2001-07-23 11:06:59 EDT
When you tried the partitionless install, did the FAT partition already exist or
did you create it with Disk Druid?
Comment 3 Need Real Name 2001-07-23 11:37:04 EDT
In the partitionless install, I had already created the FAT partition using the fdisk on a Windows boot disk. The partition table looked like this:

hda1 - NTFS for WinXP (3 Gigs)
hda2 - 16 MB of ext2 (but I ignored this partition for purposes of the partitionless install - didn't select it for anything)
hda5 - FAT partition created using a WinME boot disk

I had already created it since that's what the RH Install Guide said to do in the appendix on partitionless installs. Didn't try creating the FAT partition since 
the RH7.1 installer kept wiping the partition table - I was trying to find a way to install which didn't require partitioning.

I saw some references to the 2.4.x kernel being stricter about partition tables, so since RH6.1 and 7.0 can install my initial guess is that this may have 
something to do with the kernel. I'm no expert, though.
Comment 4 Need Real Name 2001-07-23 12:00:52 EDT
One more piece of info for you:

I have noticed (when I've caught it), that among the kernel messages that stream by while doing the initial startup of the install is a phrase to the effect of 
"couldn't read partition table". I haven't always been looking at the kernel messages while working on this issue, but I do remember seeing this more than 
once.

This would be consistent with the kernel being strict and might explain why both the regular and partitionless installs aren't working.
Comment 5 Brent Fox 2001-07-23 15:49:38 EDT
Try booting with 'linux noprobe'.  That should tell the kernel to be more
lenient in its partition table handling.  Does that help?
Comment 6 Need Real Name 2001-07-23 22:56:07 EDT
Using "linux noprobe" resulted in the same error, but "ide=nodma" did work! (I 
found a reference to this option somewhere - I forget where.)

I used "linux ide=nodma expert" and was able to manually add partitions as 
follows:

/hda1 - 3 Gigs of NTFS for WinXP
/hda2 - 16 MB for /boot - I put LILO here
/hda5 - 512MB of swap
/hda6 - the rest of the drive (about 2.5 GB) for /

I made a boot disk which I use to boot into Linux.

So, must be something about the drive that requires ide=nodma. I have to use 
this switch at each boot up or I get a kernel panic. Another project for 
another day. ;^)

Thanks for your help. You may want to put this in the Gotchas and Workarounds 
section.
Comment 7 Brent Fox 2001-07-24 19:44:38 EDT
Glad you found a workaround.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.