Bug 496771 - The PV NIC driver failed WHQL Sleep Stress with IO test win2003/32
The PV NIC driver failed WHQL Sleep Stress with IO test win2003/32
Status: CLOSED DUPLICATE of bug 679144
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-win (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
:
Depends On:
Blocks: 518435
  Show dependency treegraph
 
Reported: 2009-04-21 00:08 EDT by koka xiong
Modified: 2013-01-09 16:34 EST (History)
10 users (show)

See Also:
Fixed In Version: 1.3.4-1
Doc Type: Bug Fix
Doc Text:
When performing the Windows Hardware Quality Labs (WHQL) testing, as a result of running the "Sleep Stress with IO" test case on the para-virtualized Network Interface Card (NIC) driver, the Windows guest was unable to resume from the sleep mode.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-20 04:28:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of the unawaken guest. (149.47 KB, image/png)
2010-06-27 21:07 EDT, Xiaoli Tian
no flags Details
2k3-32-BSOD-sleep-IO (29.87 KB, image/png)
2011-02-23 02:01 EST, Huang Wenlong
no flags Details

  None (edit)
Description koka xiong 2009-04-21 00:08:15 EDT
Description of problem:
when doing WHQL PV NIC driver Sleep Stress with IO test,the system can't resume from sleep mode

Version-Release number of selected component (if applicable):
xen-pv-driver 1.0.0

How reproducible:
always

Steps to Reproduce:
1.Install win2003/32 on xen domU
2.Install xen-pv win driver on domU
3.Do WHQL PV NIC driver Sleep Stress with IO test

  
Actual results:
The windows can't resume from sleep mode

Expected results:
The windows should can resume from sleep mode

Additional info:
Comment 1 koka xiong 2009-04-21 06:22:54 EDT
when doing sleep stress with I/O with rel1839 NIC,it can pass  Sleep Stress with IO test.
Comment 5 Paolo Bonzini 2010-02-19 13:05:48 EST
This seems to be fixed in the latest drivers.
Comment 9 Xiaoli Tian 2010-06-25 04:50:18 EDT
The bug still exists while testing with xenpv-win-1.2.0-1 ,xen-3.0.3-105.el5_5.4.x86_64 and kernel 2.6.18-194.7.1.el5.
Comment 11 Jaromir Hradilek 2010-06-25 07:30:28 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
When performing the Windows Hardware Quality Labs (WHQL) testing, as a result of running the "Sleep Stress with IO" test case on the para-virtualized Network Interface Card (NIC) driver, the Windows guest was unable to resume from the sleep mode.
Comment 12 Paolo Bonzini 2010-06-25 07:42:48 EDT
Does it fail or does it hang?  If it hangs, please upgrade your kernel as in bug 497943.

Also, are you testing W2003 or something newer?  (I know this bug is for W2003, but most WHQL testing I've seen on the drivers was done with 2008 or 2008R2).

Thanks!
Comment 13 Xiaoli Tian 2010-06-27 21:06:03 EDT
(In reply to comment #12)
> Does it fail or does it hang?  If it hangs, please upgrade your kernel as in
> bug 497943.
> 
> Also, are you testing W2003 or something newer?  (I know this bug is for W2003,
> but most WHQL testing I've seen on the drivers was done with 2008 or 2008R2).
> 
> Thanks!    

It enters status as the attached screen shot below and doesn't wake up until I manually turn off it.
I have tested it in Win2008 x86,x64 and R2 which all passed " Sleep Stress with IO" testing.
Comment 14 Xiaoli Tian 2010-06-27 21:07:45 EDT
Created attachment 427282 [details]
Screen shot of the unawaken guest.
Comment 15 Xiaoli Tian 2010-06-27 23:40:14 EDT
Have tested it with with xenpv-win-1.2.0-1 ,xen-3.0.3-105.el5_5.4.x86_64 and kernel 2.6.18-204.el5 again.
It failed with the same failure as screen shot attached above.
Comment 16 Paolo Bonzini 2010-06-28 04:37:33 EDT
I'll ask management about whether we need to support W2K3 for WHQL.  In the meanwhile I'll remove this bug from the errata.  Thanks!
Comment 17 Yewei Shao 2010-11-30 05:55:38 EST
As this bug still not fixed now, so confirmed with Paolo in IRC, move this bug to 5.7, thanks.
Comment 19 RHEL Product and Program Management 2011-01-11 15:14:00 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 20 RHEL Product and Program Management 2011-01-12 10:23:35 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 21 Huang Wenlong 2011-02-23 02:01:20 EST
Created attachment 480350 [details]
2k3-32-BSOD-sleep-IO
Comment 22 Huang Wenlong 2011-02-23 02:01:47 EST
I tested this bug in win2k3-32 guest with xenpv-win-1.3.3-1  and get BSOD 
please check attachment when run the  job of Sleep Stress with IO 

I do "regedit"  set the NetworkNoChecksumOffload = 1
Comment 23 Paolo Bonzini 2011-02-23 02:36:11 EST
So there is still a memory leak.  Thanks!
Comment 25 Huang Wenlong 2011-03-02 02:08:26 EST
Test Version:
xenpv-win-1.3.4-2.el5
xen-3.0.3-123.el5
kernel-xen-2.6.18-245.el5

Test platform:
win2k3-32

Test Steps:
1. Install xenpv-win driver in win2k3-32 guest.
2. set the NetworkNoChecksumOffload = 1
3. Run  Sleep Stress with IO 

Test Result:
Sleep Stress with IO    -- PASS
Comment 26 Paolo Bonzini 2011-05-20 04:28:23 EDT

*** This bug has been marked as a duplicate of bug 679144 ***

Note You need to log in before you can comment on or make changes to this bug.