Bug 496785 - 4 States of Needinfo Flag
4 States of Needinfo Flag
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Administration (Show other bugs)
3.2
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 02:59 EDT by CAI Qian
Modified: 2013-06-23 22:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 10:21:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CAI Qian 2009-04-21 02:59:39 EDT
Description of problem:
Currently, needinfo flag has 4 states: +, -, <blank> and ?. I am not
entirely clear what is the purpose of +, - and <blank> here. Does anyone
need to cancel or grant or decline a needinfo?

Version-Release number of selected component (if applicable):
3.2

How reproducible:
always
Comment 1 Noura El hawary 2009-04-21 08:25:00 EDT
Hi Cai,

Basically the <blank> for needinfo it to remove/clear the flag,, so if you set it to blank means that the bug no longer has the needinfo flag set for it. for the other states, the needinfo flag is just like any other flag plus it is a replacement of the previous bug status we has which was NEEDINFO so if the needinfo flag is set to ? this means that the flag need info from someone and it is equivalent to the case of setting the bug status previously to NEEDINFO,, also use can set the status to + meaning that they are satisfied with the information provided or they can set it to - meaning that they are not satisfied with the provided info, those states are valid and some people use it for the needinfo flag 

I hope this answered your question.

I will close the bug, if you feel that this is a bug please reopen it with your justification.

Cheers,
Noura
Comment 2 CAI Qian 2009-04-21 08:57:21 EDT
I understood the purpose of <blank> and ?, but I am still confused about
+ and - states. If a requestor is unhappy about the information
provided, he/she can set the flag to ? again to re-request the
information. In addition, we can see that the bug is now blocking on
further information from the other party in the summary.

One of my colleagues was also confused with those states had tried to
set the flag to -, but then it seemed the NEEDINFO was disappeared from
the summary. Therefore, it is a difficult to know where we are blocking
now from the summary.
Comment 3 David Lawrence 2009-04-21 10:17:12 EDT
In theory the Needinfo flag should never be anything other than <blank> or ?. The
+ and - are states that come along with being a flag but are not useful for needinfo. A needinfo? flag should be considered blocking the bug due to information being needed before proceeding. Users should only use the UI beneath the comments textarea for managing the needinfo flags and not use the flags interface directly.

Which reminds me, that we should probably have a sanity check for needinfo flags that are in either a + or - state so that a Bugzilla admin can clear them. I will file a different bug for that.
Comment 4 CAI Qian 2009-04-23 03:47:37 EDT
I agree with David, so I re-open this bug.
Comment 5 David Lawrence 2009-04-23 10:21:25 EDT
New bug for the sanitycheck already filed in bug 497031 so need to reopen this bug.

Dave

Note You need to log in before you can comment on or make changes to this bug.