Bug 496837 - Rawhide: Clicking on Buttons on KDE4 notifications from KPackageKit doesn't have any effect
Summary: Rawhide: Clicking on Buttons on KDE4 notifications from KPackageKit doesn't h...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kpackagekit
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Steven M. Parrish
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-04-21 12:30 UTC by Brian Vuyk
Modified: 2009-04-22 19:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-04-22 19:22:39 UTC


Attachments (Terms of Use)
Screenshot of the broken notification dialog (19.06 KB, image/png)
2009-04-21 12:32 UTC, Brian Vuyk
no flags Details

Description Brian Vuyk 2009-04-21 12:30:17 UTC
Description of problem:

The notification is the one in the attached screenshot.

Essentially, clicking on the 'Review and update', 'Not now', and 'Do not ask again' buttons has no effect. They don't appear to trigger any actions. 

This is on rawhide, updated to April 20, 2009.

Comment 1 Brian Vuyk 2009-04-21 12:32:13 UTC
Created attachment 340510 [details]
Screenshot of the broken notification dialog

Apparently bugzilla decided not to upload the screenshot I told it to. Trying again.

Comment 2 Rex Dieter 2009-04-21 13:57:11 UTC
Odd, works for me.

rpm -q PackageKit kpackagekit
please.

Comment 3 Brian Vuyk 2009-04-21 14:01:27 UTC
[root@localhost brian]# rpm -q PackageKit kpackagekit
PackageKit-0.4.6-3.fc11.i586
kpackagekit-0.4.0-6.fc11.i586
[root@localhost brian]#

Comment 4 Brian Vuyk 2009-04-21 14:03:54 UTC
I should clarify, it is impossible to get rid of this notification. It remains in the system tray. Even though I've update all the packages, it is still sitting minimized in the tray.

Comment 5 Rex Dieter 2009-04-21 14:08:07 UTC
So... you updated via some non-kpackagekit method?  (yum?)

Comment 6 Brian Vuyk 2009-04-21 14:40:24 UTC
I updated using yum, hoping that kpackagekit would see the new packages and suppress the notification.

Comment 7 Kevin Kofler 2009-04-21 16:11:01 UTC
Looks like some more breakage from the Plasma notifications. :-(

Comment 8 Brian Vuyk 2009-04-22 19:16:10 UTC
Just to update,

today it worked fine. I don't know if there were any changes in the meantime... I doubt it.

Comment 9 Rex Dieter 2009-04-22 19:22:39 UTC
ok, let us know if it ever happens again.


Note You need to log in before you can comment on or make changes to this bug.