Bug 496837 - Rawhide: Clicking on Buttons on KDE4 notifications from KPackageKit doesn't have any effect
Rawhide: Clicking on Buttons on KDE4 notifications from KPackageKit doesn't h...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 08:30 EDT by Brian Vuyk
Modified: 2009-04-22 15:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 15:22:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the broken notification dialog (19.06 KB, image/png)
2009-04-21 08:32 EDT, Brian Vuyk
no flags Details

  None (edit)
Description Brian Vuyk 2009-04-21 08:30:17 EDT
Description of problem:

The notification is the one in the attached screenshot.

Essentially, clicking on the 'Review and update', 'Not now', and 'Do not ask again' buttons has no effect. They don't appear to trigger any actions. 

This is on rawhide, updated to April 20, 2009.
Comment 1 Brian Vuyk 2009-04-21 08:32:13 EDT
Created attachment 340510 [details]
Screenshot of the broken notification dialog

Apparently bugzilla decided not to upload the screenshot I told it to. Trying again.
Comment 2 Rex Dieter 2009-04-21 09:57:11 EDT
Odd, works for me.

rpm -q PackageKit kpackagekit
please.
Comment 3 Brian Vuyk 2009-04-21 10:01:27 EDT
[root@localhost brian]# rpm -q PackageKit kpackagekit
PackageKit-0.4.6-3.fc11.i586
kpackagekit-0.4.0-6.fc11.i586
[root@localhost brian]#
Comment 4 Brian Vuyk 2009-04-21 10:03:54 EDT
I should clarify, it is impossible to get rid of this notification. It remains in the system tray. Even though I've update all the packages, it is still sitting minimized in the tray.
Comment 5 Rex Dieter 2009-04-21 10:08:07 EDT
So... you updated via some non-kpackagekit method?  (yum?)
Comment 6 Brian Vuyk 2009-04-21 10:40:24 EDT
I updated using yum, hoping that kpackagekit would see the new packages and suppress the notification.
Comment 7 Kevin Kofler 2009-04-21 12:11:01 EDT
Looks like some more breakage from the Plasma notifications. :-(
Comment 8 Brian Vuyk 2009-04-22 15:16:10 EDT
Just to update,

today it worked fine. I don't know if there were any changes in the meantime... I doubt it.
Comment 9 Rex Dieter 2009-04-22 15:22:39 EDT
ok, let us know if it ever happens again.

Note You need to log in before you can comment on or make changes to this bug.