Bug 496862 - Battery charge level not available on MacBook 2.1
Battery charge level not available on MacBook 2.1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 09:50 EDT by Fabian Deutsch
Modified: 2009-11-25 07:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-25 07:27:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
acpitool -e (2.10 KB, text/plain)
2009-04-21 09:50 EDT, Fabian Deutsch
no flags Details
dmesg (39.38 KB, text/plain)
2009-04-21 09:51 EDT, Fabian Deutsch
no flags Details

  None (edit)
Description Fabian Deutsch 2009-04-21 09:50:52 EDT
Created attachment 340526 [details]
acpitool -e

Description of problem:
either gnome-power-manager nor acpitool -B nor /proc/acpi/BAT?/state gives me informations about my battery charge level on my Macbok.


Version-Release number of selected component (if applicable):
F10 with lates rawhide kernel: Linux proprietary.local 2.6.29.1-68.fc11.i586 #1 SMP Sat Apr 11 02:06:17 EDT 2009 i686 i686 i386 GNU/Linux

How reproducible:
Always.

Steps to Reproduce:
1. Install recent rawhide kernel
2. run: sudo acpitool -B
  
Actual results:
No charge informations

Expected results:
Informations about the charge level.

Additional info:
The problem did not appear whe using the original F10 kernel. But at some point it was broken.
Comment 1 Fabian Deutsch 2009-04-21 09:51:46 EDT
Created attachment 340529 [details]
dmesg
Comment 2 Steven M. Parrish 2009-04-21 09:54:08 EDT
Reassigning to correct component
Comment 3 Zdenek Prikryl 2009-04-21 10:03:56 EDT
In dmesg output there is this warning:

ACPI Warning (nspredef-0940): \_SB_.BAT0._BIF: Return Package type mismatch at index 9 - found Integer, expected String/Buffer [20081204]

It seems that this is kernel bug, so reassigning to kernel. Similar bug is discussed here: http://bugzilla.kernel.org/show_bug.cgi?id=11822.
Comment 4 Fabian Deutsch 2009-04-21 10:20:22 EDT
The mentioned bug seems to be related. But it should have been fixed in  2.6.28-rc6-git2 upstream ...
Comment 5 Bug Zapper 2009-06-09 10:18:31 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Fabian Deutsch 2009-10-07 09:55:30 EDT
It seems as if this fixed in the current rawhide and can be closed.

Note You need to log in before you can comment on or make changes to this bug.