Bug 496863 - 'Construct' button creates incorrect referral urls
'Construct' button creates incorrect referral urls
Status: CLOSED CURRENTRELEASE
Product: Red Hat Directory Server
Classification: Red Hat
Component: Directory Console (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks: 434914 434915
  Show dependency treegraph
 
Reported: 2009-04-21 09:52 EDT by Issue Tracker
Modified: 2016-05-06 10:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-06 10:32:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
496863-389-ds-console.patch (1.12 KB, patch)
2010-04-02 13:02 EDT, Endi Sukma Dewata
rmeggins: review+
Details | Diff
496863-idm-console-framework.patch (5.83 KB, patch)
2010-04-02 13:07 EDT, Endi Sukma Dewata
rmeggins: review+
Details | Diff

  None (edit)
Description Issue Tracker 2009-04-21 09:52:59 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2009-04-21 09:53:00 EDT
Summary: When the customer uses the construct button to create referral
URLs in the Directory Server console, the URLs created contain spaces
which cause them not to work. Removing the space from the URL seems to be
enough to get a working URL, but customer would like this addressed. I
haven't seen any existing BZ's on this yet.


This event sent from IssueTracker by mpoole  [Support Engineering Group]
 issue 277133
Comment 2 Martin Poole 2009-04-21 10:04:27 EDT
If you use the 'Construct' button to create the referral urls, the referrals don't work. It puts a space between the domain name components, e.g.:

Using the 'Construct' button results in this URL:

ldap://ldap.example.com:389/dc=example, dc=com
(note the space after dc=example, )

Instead, if you enter the URL manually as below and add it, the referrals work:
ldap://ldap.example.com:389/dc=example,dc=com

This appears in both the suffix referral settings and the userroot replication settings.
Comment 3 Martin Poole 2009-04-21 10:06:52 EDT
As rfc2255, tail of section 3 notes ...


   Note that any URL-illegal characters (e.g., spaces), URL special
   characters (as defined in section 2.2 of RFC 1738) and the reserved
   character '?' (ASCII 63) occurring inside a dn, filter, or other
   element of an LDAP URL MUST be escaped using the % method described
   in RFC 1738 [5]. If a comma character ',' occurs inside an extension
   value, the character MUST also be escaped using the % method.
Comment 4 Endi Sukma Dewata 2010-04-02 13:02:47 EDT
Created attachment 404214 [details]
496863-389-ds-console.patch

The com.netscape.admin.dirserv.panel.LDAPUrlDialog.notifyUpdate() has been modified to encode the base DN of the LDAP URL.
Comment 5 Endi Sukma Dewata 2010-04-02 13:07:05 EDT
Created attachment 404215 [details]
496863-idm-console-framework.patch

The com.netscape.management.client.ug.LdapQueryBuilderDialog.createQueryString() has been modified to encode the base DN and the filter of the LDAP URL.
Comment 6 Rich Megginson 2010-04-02 13:49:06 EDT
Checking in src/com/netscape/management/client/ug/LdapQueryBuilderDialog.java;
/cvs/dirsec/console/src/com/netscape/management/client/ug/LdapQueryBuilderDialog.java,v  <--  LdapQueryBuilderDialog.java
new revision: 1.2; previous revision: 1.1

To ssh://git.fedorahosted.org/git/389/ds-console.git
   ab373d5..66871c5  master -> master
commit 66871c50937eede01d26052ea6e355fbdfb5ab57
Author: Endi S. Dewata <edewata@redhat.com>
Date:   Sun Mar 28 12:10:04 2010 -0500
Comment 9 Jenny Galipeau 2010-06-03 14:53:18 EDT
verified - RHEL 4

versions:
redhat-ds-admin-8.2.0-3.el4dsrv
redhat-ds-base-8.2.0-2010060304.el4dsrv
redhat-ds-console-8.2.0-3.el4dsrv
redhat-admin-console-8.2.0-2.el4dsrv
redhat-idm-console-1.0.1-1.el4idm


construction URL for replication and for the suffix  
I am getting the following ... 
ldap://jennyv4.bos.redhat.com:389/dc%3dexample,dc%3dcom

Note You need to log in before you can comment on or make changes to this bug.