Bug 49688 - rpm segfault with older .rpm files
Summary: rpm segfault with older .rpm files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-23 10:40 UTC by Pekka Savola
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-23 20:56:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2001-07-23 10:40:11 UTC
Some very old rpm's appear to behave badly with beta2 rpm.  These worked
fine in RHL71; I suppose the not working is not intentional (e.g. removed
support
for old packaging format) because then rpm should exit more gracefully..

E.g. a proprietary backup software available at:

ftp://ftp.legato.com/pub/Unsupported/Linux_Client/

lgtoclnt-rh-5.1.0-2.i386.rpm
lgtoman-rh-5.1.0-2.i386.rpm

The former dies with:

# rpm -Uvh lgtoclnt-rh-5.1.0-2.i386.rpm 
Preparing...                ###########################################
[100%]
*** not mapped mminfo
   1:lgtoclnt-rh            Segmentation fault (core dumped)            ( 
4%)

And the latter:

]# rpm -Uvh lgtoman-rh-5.1.0-2.i386.rpm  
Preparing...                ###########################################
[100%]
*** not mapped man1/rapgen.1
error: unpacking of archive failed on file man1/rapgen.1: cpio: open failed
- No such file or directory
   1:lgtoman-rh

Comment 1 Glen Foster 2001-07-23 20:36:13 UTC
The rpm package has undergone quite a bit of work between betas 2 and 3.  Please
try this again with beta-3 and we'll escalate the importance then (if needed).

Comment 2 Pekka Savola 2001-07-23 20:43:33 UTC
status for now: rpm-4.0.3-0.66 (beta2) or latest rawhide (Jul 12) rpm-4.0.3-0.69 no workee.


Comment 3 Jeff Johnson 2001-07-23 20:56:49 UTC
No workeee in -0.80 either, dunno if there will be a "fix" in rpm-4.0.3,
as those packages are pretty old and broken AFAIAC. For example,
there are also symlinks pointing to the buildroot, in addition to the
absolute paths carried in header metadata.

Yes, no matter what, the segfault will be avoided ...

Comment 4 Jeff Johnson 2001-07-24 20:27:41 UTC
OK, I respectfully decline to support rpm-2.4.10 packaging because
files in the payload have borked and incomplete paths:

 rpm2cpio lgtoclnt-rh-5.1.0-2.i386.rpm | cpio -itv
-rwxr-xr-x   1 root     root       230524 Aug 28  1998 mminfo
-rwxr-xr-x   1 root     root       166748 Aug 28  1998 mmlocate
-rwxr-xr-x   1 root     root       165080 Aug 28  1998 mmpool
-rwxr-xr-x   1 root     root       166256 Aug 28  1998 mmrecov
-rwxr-xr-x   1 root     root          873 Aug 28  1998 networker.rh
-rwxr-xr-x   1 root     root        13207 Aug 28  1998 nsr_shutdown
-rwxr-xr-x   1 root     root       200232 Aug 28  1998 nsradmin
-rwxr-xr-x   1 root     root       182912 Aug 28  1998 nsralist
-rwxr-xr-x   1 root     root       397384 Aug 28  1998 nsrarchive
-rwxr-xr-x   1 root     root       214172 Aug 28  1998 nsrclone
-rwxr-xr-x   1 root     root       151960 Aug 28  1998 nsrexec
-rwxr-xr-x   1 root     root       197676 Aug 28  1998 nsrexecd
-rwxr-xr-x   1 root     root       301876 Aug 28  1998 nsrfile
-rwxr-xr-x   1 root     root       213180 Aug 28  1998 nsrmm
lrwxrwxrwx   1 root     root           29 Aug 28  1998 nsrretrieve ->
/tmp/lgtcoln/usr/sbin/recover
-rwxr-xr-x   1 root     root       188340 Aug 28  1998 nsrwatch
-rwxr-xr-x   1 root     root        66716 Aug 28  1998 preclntsave
-rwxr-xr-x   1 root     root       179380 Aug 28  1998 pstclntsave
-rwxr-xr-x   1 root     root       437844 Aug 28  1998 recover
-rwxr-xr-x   1 root     root       368204 Aug 28  1998 save
-rwxr-xr-x   1 root     root       224816 Aug 28  1998 savefs
-rwxr-xr-x   1 root     root       312528 Aug 28  1998 savegrp
lrwxrwxrwx   1 root     root           26 Aug 28  1998 savepnpc ->
/tmp/lgtcoln/usr/sbin/save
-rwxr-xr-x   1 root     root       297552 Aug 28  1998 uasm

Note also the broken symlinks. Fix the package I say ...

Meanwhile, the segfault is fixed in rpm-4.0.3-0.82 by adding an error
message for the condiftion that the archive path != header metadata path.



Note You need to log in before you can comment on or make changes to this bug.