Bug 496963 - PDE Build wrapper script does not handle symbolic links properly
PDE Build wrapper script does not handle symbolic links properly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 16:24 EDT by Elliott Baron
Modified: 2009-07-02 01:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.4.2-11.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-02 01:45:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Revised patch to overwrite symlink targets (13.15 KB, patch)
2009-04-21 16:24 EDT, Elliott Baron
no flags Details | Diff

  None (edit)
Description Elliott Baron 2009-04-21 16:24:23 EDT
Created attachment 340628 [details]
Revised patch to overwrite symlink targets

Description of problem:
The prepare-build-dir.sh script called by PDE Build will improperly create symbolic links under the target directory instead of overwriting the target directory.

Version-Release number of selected component (if applicable):
3.4.2-2.fc11

How reproducible:
Run PDE Build without cleaning up the directory structure containing checked out plugins. Running PDE Build again will create the above problem.
Comment 1 Andrew Overholt 2009-04-21 16:39:52 EDT
Thanks for the patch, Elliott.

Due to potential issues with 3.4.2 and updates (p2 dropins issue), I'd like to get this in before F-11 GA if possible.  Alex, what do you think?
Comment 2 Alexander Kurtakov 2009-04-22 03:39:06 EDT
Do you think it classifies for a https://fedoraproject.org/wiki/ReleaseEngineering/FinalFreezePolicy break? It doesn't have such big impact so I would vote for just committing it in F-11 so it get in the next update build with some other changes. 

Btw, I'm applying it for F-12.
Comment 3 Andrew Overholt 2009-04-22 08:56:21 EDT
I agree it can wait for an F-11 update.  I've committed it in the F-11 directory and it will get picked up in the next build.
Comment 4 Bug Zapper 2009-06-09 10:21:20 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Fedora Update System 2009-06-18 16:58:04 EDT
eclipse-3.4.2-11.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/eclipse-3.4.2-11.fc11
Comment 6 Fedora Update System 2009-06-24 15:34:02 EDT
eclipse-3.4.2-11.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update eclipse'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6919
Comment 7 Fedora Update System 2009-07-02 01:45:17 EDT
eclipse-3.4.2-11.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.